summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-04 16:07:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-05 09:12:39 +0200
commitab66c9a2cda10edfbf5f2f11481d4d2d1d604bf5 (patch)
tree752b954cccb71bb59b12247d32346683fa2d00cc /gnu/packages/cran.scm
parentb71f21339ff0c9ded5f6dc3e15d0ea7ab55f6578 (diff)
downloadguix-patches-ab66c9a2cda10edfbf5f2f11481d4d2d1d604bf5.tar
guix-patches-ab66c9a2cda10edfbf5f2f11481d4d2d1d604bf5.tar.gz
gnu: Add r-arrow.
* gnu/packages/cran.scm (r-arrow): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cf24d0fb37..2e7e9041c6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17746,6 +17746,43 @@ colored by the number of neighboring points. This is useful to visualize the
2D-distribution of points in case of overplotting.")
(license license:gpl3)))
+(define-public r-arrow
+ (package
+ (name "r-arrow")
+ (version "4.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "arrow" version))
+ (sha256
+ (base32
+ "19kzfjxp90ybi1px3r93mfx59nqmnagxr4g73y7iby5blwl1bblc"))))
+ (properties `((upstream-name . "arrow")))
+ (build-system r-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-bit64" ,r-bit64)
+ ("r-cpp11" ,r-cpp11)
+ ("r-purrr" ,r-purrr)
+ ("r-r6" ,r-r6)
+ ("r-rlang" ,r-rlang)
+ ("r-tidyselect" ,r-tidyselect)
+ ("r-vctrs" ,r-vctrs)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/apache/arrow/")
+ (synopsis "R integration to Apache Arrow")
+ (description
+ "Apache Arrow is a cross-language development platform for in-memory
+data. It specifies a standardized language-independent columnar memory format
+for flat and hierarchical data, organized for efficient analytic operations on
+modern hardware. This package provides an R interface to the Arrow C++
+library.")
+ (license license:asl2.0)))
+
(define-public r-rex
(package
(name "r-rex")