summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 13:32:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:57 +0100
commit9cd3ae8620ed27fb54da1face9ec1a4265746602 (patch)
tree9dfb6515b28a82e0f1460e25b57265b5f6c4f957 /gnu/packages/cran.scm
parent86a760cc67170331abcb1f0bdf73af4716effad5 (diff)
downloadguix-patches-9cd3ae8620ed27fb54da1face9ec1a4265746602.tar
guix-patches-9cd3ae8620ed27fb54da1face9ec1a4265746602.tar.gz
gnu: Add r-icge.
* gnu/packages/cran.scm (r-icge): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 354837823b..8482f274b6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18486,3 +18486,27 @@ In addition, the package provides methods for data
preprocessing (normalization and discretization), visualization, and
validation of bicluster solutions.")
(license license:gpl3)))
+
+(define-public r-icge
+ (package
+ (name "r-icge")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ICGE" version))
+ (sha256
+ (base32
+ "0xin7zml1nbygyi08hhg3wwr2jr1zcsvrlgia89zp4xanxlzgaqa"))))
+ (properties `((upstream-name . "ICGE")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cluster" ,r-cluster)
+ ("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/web/packages/ICGE/")
+ (synopsis "Cluster estimation and identification of atypical units")
+ (description
+ "ICGE is a package that helps to estimate the number of real clusters in
+data as well as to identify atypical units. The underlying methods are based
+on distances rather than on unit x variables.")
+ (license license:gpl2+)))