summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-27 13:55:33 +0200
committerRoel Janssen <roel@gnu.org>2021-05-27 13:55:33 +0200
commit89fd577ec2c0a431d0522617227ee99447b3db6c (patch)
treea8755c15460eacbab3b979407fbb3bbb4b17c463 /gnu/packages/cran.scm
parentcf9ddbd4bcd0f5c76234e03d7986f8639d11bd83 (diff)
downloadguix-patches-89fd577ec2c0a431d0522617227ee99447b3db6c.tar
guix-patches-89fd577ec2c0a431d0522617227ee99447b3db6c.tar.gz
gnu: Add r-rffc.
* gnu/packages/cran.scm (r-rffc): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 894f2bc4d7..56e74da32d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25658,6 +25658,30 @@ maximums, many t, F and G-square tests, many regressions (normal, logistic,
Poisson), are some of the many fast functions.")
(license license:gpl2+)))
+(define-public r-rffc
+ (package
+ (name "r-rffc")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.r-forge.r-project.org/src/contrib/"
+ "rfFC_" version ".tar.gz"))
+ (sha256
+ (base32
+ "05x9wgzsmx4vb12lmcspymgmpb2xw8bwryb8ysg7vzg2nkh0ma3g"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-randomforest",r-randomforest)))
+ (home-page "https://r-forge.r-project.org/projects/rffc/")
+ (synopsis "Random Forest Feature Contributions")
+ (description "This package provides functions for extracting feature
+contributions from a random forest model from package @code{randomForest}.
+Feature contributions provide detailed information about the relationship
+between data variables and the predicted value returned by random forest
+model.")
+ (license license:gpl2)))
+
(define-public r-clusterr
(package
(name "r-clusterr")