summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 22:46:06 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 22:46:06 +0200
commit84d551d45ecf360fd0399395330d1eac03cd80e9 (patch)
tree779149bc5f8d43e141d3b53ee003eeaef6886cd5 /gnu/packages/cran.scm
parentb7664dfb780336114c229683b87d3564e9a72268 (diff)
downloadguix-patches-84d551d45ecf360fd0399395330d1eac03cd80e9.tar
guix-patches-84d551d45ecf360fd0399395330d1eac03cd80e9.tar.gz
gnu: Add r-howmany.
* gnu/packages/cran.scm (r-howmany): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 19aa2b407b..e59431ac5f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1382,6 +1382,29 @@ documents that can be converted to HTML files (e.g., R Markdown) under a given
directory.")
(license license:expat)))
+(define-public r-howmany
+ (package
+ (name "r-howmany")
+ (version "0.3-1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "howmany" version))
+ (sha256
+ (base32
+ "045ck8qahfg2swbgyf7dpl32ryq1m4sbalhr7m5qdgpm62vz8h7f"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/howmany/")
+ (synopsis "Lower bound for the number of correct rejections")
+ (description "When testing multiple hypotheses simultaneously, this package
+provides functionality to calculate a lower bound for the number of correct
+rejections (as a function of the number of rejected hypotheses), which holds
+simultaneously -with high probability- for all possible number of rejections.
+As a special case, a lower bound for the total number of false null hypotheses
+can be inferred. Dependent test statistics can be handled for multiple tests
+of associations. For independent test statistics, it is sufficient to provide
+a list of p-values.")
+ (license license:gpl2+)))
+
(define-public r-htmltools
(package
(name "r-htmltools")