summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 10:56:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:56 +0100
commit7faa05377eda6b7ec5d9292da435f1534285f3dd (patch)
tree24996a7130535749da826e5f6f98898c7a516ef9 /gnu/packages/cran.scm
parent1830e0383b808a1a1b943f714335cf36efc38795 (diff)
downloadguix-patches-7faa05377eda6b7ec5d9292da435f1534285f3dd.tar
guix-patches-7faa05377eda6b7ec5d9292da435f1534285f3dd.tar.gz
gnu: Add r-actuar.
* gnu/packages/cran.scm (r-actuar): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7bb4726fd1..1f0ebea2c1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18155,3 +18155,31 @@ function @code{G(a, x)} defined for negative values of its first argument.
The package also gives easy access to the underlying C routines through an
API; see the package vignette for details.")
(license license:gpl2+)))
+
+(define-public r-actuar
+ (package
+ (name "r-actuar")
+ (version "2.3-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "actuar" version))
+ (sha256
+ (base32
+ "0aw3hlan5y22mdqk1wvnw9ksqhwp4yy5hi0dpv21p7s0hyxhphih"))))
+ (properties `((upstream-name . "actuar")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-expint" ,r-expint)))
+ (home-page "https://gitlab.com/vigou3/actuar")
+ (synopsis "Actuarial functions and heavy tailed distributions")
+ (description
+ "This package provides functions and data sets for actuarial science:
+modeling of loss distributions; risk theory and ruin theory; simulation of
+compound models, discrete mixtures and compound hierarchical models;
+credibility theory. It boasts support for many additional probability
+distributions to model insurance loss amounts and loss frequency: 19
+continuous heavy tailed distributions; the Poisson-inverse Gaussian discrete
+distribution; zero-truncated and zero-modified extensions of the standard
+discrete distributions. It also supports phase-type distributions commonly
+used to compute ruin probabilities.")
+ (license license:gpl2+)))