summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-11-18 16:40:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 12:12:21 +0100
commit755d16a3b0494fcddfa46e40bcf494abbd278509 (patch)
tree82b70f36b8e9fd9f03042ad7e5e7681251e7a97a /gnu/packages/cran.scm
parentdeda2319f7f2ab0038311b847e31d5f6b5877f6e (diff)
downloadguix-patches-755d16a3b0494fcddfa46e40bcf494abbd278509.tar
guix-patches-755d16a3b0494fcddfa46e40bcf494abbd278509.tar.gz
gnu: Add r-mixsqp.
* gnu/packages/cran.scm (r-mixsqp): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 855b45e597..60fac20c03 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8636,6 +8636,37 @@ conveniently wrapped into a data frame.")
multiple-imputation datasets.")
(license license:gpl2)))
+(define-public r-mixsqp
+ (package
+ (name "r-mixsqp")
+ (version "0.3-43")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mixsqp" version))
+ (sha256
+ (base32
+ "1qics04w0swyp216d6g8dmsph8q2kpadpacp66h2qih3521js12q"))))
+ (properties `((upstream-name . "mixsqp")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-irlba" ,r-irlba)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/stephenslab/mixsqp")
+ (synopsis
+ "Sequential quadratic programming for maximum-likelihood estimation")
+ (description
+ "This package provides an optimization method based on sequential
+quadratic programming for maximum likelihood estimation of the mixture
+proportions in a finite mixture model where the component densities are
+known. The algorithm is expected to obtain solutions that are at least
+as accurate as the state-of-the-art MOSEK interior-point solver, and they
+are expected to arrive at solutions more quickly when the number of
+samples is large and the number of mixture components is not too large.")
+ (license license:expat)))
+
(define-public r-magick
(package
(name "r-magick")