summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-04 22:41:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-04 22:41:35 +0100
commit5ae09d7979a0696d862b9555314eab199f7ce576 (patch)
treeefce1080499d913fe80520d5e1f03894342afcfc /gnu/packages/cran.scm
parent8f78b6fcf5f4a23a04dbed276f4f130069318245 (diff)
downloadguix-patches-5ae09d7979a0696d862b9555314eab199f7ce576.tar
guix-patches-5ae09d7979a0696d862b9555314eab199f7ce576.tar.gz
gnu: Add r-spelling.
* gnu/packages/cran.scm (r-spelling): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6238554167..c420bc0332 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1820,6 +1820,36 @@ page dashboard or a multi-page template, where the navigation menu is
contained in the navigation bar.")
(license license:gpl2+)))
+(define-public r-spelling
+ (package
+ (name "r-spelling")
+ (version "2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "spelling" version))
+ (sha256
+ (base32
+ "179nj9w1v27qq9q5240ddvggp0795998sxyqjvbqjvq9dmach3bl"))))
+ (properties `((upstream-name . "spelling")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-commonmark" ,r-commonmark)
+ ("r-hunspell" ,r-hunspell)
+ ("r-knitr" ,r-knitr)
+ ("r-xml2" ,r-xml2)))
+ (home-page "https://docs.ropensci.org/spelling/")
+ (synopsis "Tools for spell checking in R")
+ (description
+ "This is an R package for spell checking common document formats
+including LaTeX, markdown, manual pages, and DESCRIPTION files. It includes
+utilities to automate checking of documentation and vignettes as a unit test
+during @code{R CMD check}. Both British and American English are supported
+out of the box and other languages can be added. In addition, packages may
+define a wordlist to allow custom terminology without having to abuse
+punctuation.")
+ (license license:expat)))
+
(define-public r-crosstalk
(package
(name "r-crosstalk")