summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-27 19:48:20 +0800
committerLudovic Courtès <ludo@gnu.org>2020-07-13 12:52:53 +0200
commit565bf214ad0258c66eef22c48e13c902a77ac439 (patch)
tree0f52f22683e145f77d5cd2463925b627ef36eb9d /gnu/packages/cran.scm
parentf28c09f2fc24f282d91c0c77c7a7722da0b82c44 (diff)
downloadguix-patches-565bf214ad0258c66eef22c48e13c902a77ac439.tar
guix-patches-565bf214ad0258c66eef22c48e13c902a77ac439.tar.gz
gnu: Add r-semver.
* gnu/packages/cran.scm (r-semver): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1ff7941baf..60a99d1664 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22396,3 +22396,29 @@ databases, including PubMed. The name RISmed is a portmanteau of
RIS (for Research Information Systems, a common tag format for
bibliographic data) and PubMed.")
(license license:gpl2+)))
+
+(define-public r-semver
+ (package
+ (name "r-semver")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "semver" version))
+ (sha256
+ (base32
+ "10wpkyms2cix3bsin2q0qhkbl445pwwpa5gm2s4jjw1989namkxy"))))
+ (properties `((upstream-name . "semver")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-rcpp" ,r-rcpp)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/johndharrison/semver")
+ (synopsis "Parser for Semantic Versioning 2.0.0")
+ (description
+ "This package provides tools and functions for parsing, rendering and
+operating on semantic version strings. Semantic versioning is a simple set of
+rules and requirements that dictate how version numbers are assigned and
+incremented as outlined at @url{http://semver.org}.")
+ (license license:expat)))