summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 09:52:12 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 09:52:12 +0200
commit3f2a4b098039bd374c76d524223de3c6c475f23e (patch)
treed703f6f5819bf11f43bd1d027f1eaad76fcba391 /gnu/packages/cran.scm
parent9048e7f3b4d53a61050a8c1f0d47f7a1f637478f (diff)
downloadguix-patches-3f2a4b098039bd374c76d524223de3c6c475f23e.tar
guix-patches-3f2a4b098039bd374c76d524223de3c6c475f23e.tar.gz
gnu: Add r-pvclust.
* gnu/packages/cran.scm (r-pvclust): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8709cd21fa..949c74f0e8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2894,6 +2894,26 @@ attaching it. This is a key part of the @code{devtools} package as it allows
you to rapidly iterate while developing a package.")
(license license:gpl3)))
+(define-public r-pvclust
+ (package
+ (name "r-pvclust")
+ (version "2.2-0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "pvclust" version))
+ (sha256
+ (base32
+ "0082icm54k2yq60k06qpr92a626k39j2jr0046lva4ylmhxqb4kq"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/shimo-lab/pvclust")
+ (synopsis
+ "Hierarchical clustering with P-values via multiscale bootstrap resampling")
+ (description "This package provides an implementation of multiscale bootstrap
+resampling for assessing the uncertainty in hierarchical cluster analysis. It
+provides an AU (approximately unbiased) P-value as well as a BP (bootstrap probability)
+value for each cluster in a dendrogram.")
+ (license license:gpl2+)))
+
(define-public r-rcpp
(package
(name "r-rcpp")