summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-09 16:53:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-09 16:57:13 +0100
commit3a4c6288c81d91ce48200a310ad0d83bddfb7a5a (patch)
tree11251feaf26a6fe83e653df779b7923f831e80a6 /gnu/packages/cran.scm
parent8a587c89af55d7fa858a65fe717cfbfbe84b0e1e (diff)
downloadguix-patches-3a4c6288c81d91ce48200a310ad0d83bddfb7a5a.tar
guix-patches-3a4c6288c81d91ce48200a310ad0d83bddfb7a5a.tar.gz
gnu: Add r-aggregation.
* gnu/packages/cran.scm (r-aggregation): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ec950ce0ac..33dda347b5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3071,6 +3071,26 @@ Analysis for Physical Applications, Donald B. Percival and Andrew T. Walden,
Cambridge University Press, 1993.")
(license license:gpl2)))
+(define-public r-aggregation
+ (package
+ (name "r-aggregation")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "aggregation" version))
+ (sha256
+ (base32
+ "0j9g604m2ccc7hcy02539yja9cf3xcbl25gvp838bp4x8w18my46"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/aggregation/")
+ (synopsis "Methods for p-value aggregation")
+ (description
+ "This package contains functionality for performing the following methods
+of p-value aggregation: Fisher's method, the Lancaster method (weighted
+Fisher's method), and Sidak correction.")
+ (license license:gpl3)))
+
(define-public r-quantmod
(package
(name "r-quantmod")