summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-02 23:04:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-02 23:05:49 +0100
commit1e07875b577a197730b363bdbf0d9d4da8011571 (patch)
treed0695e62ff7ac151af382b600c56049368811662 /gnu/packages/cran.scm
parent02366a12d0a544028055cf8a4f4dfddff2e811e0 (diff)
downloadguix-patches-1e07875b577a197730b363bdbf0d9d4da8011571.tar
guix-patches-1e07875b577a197730b363bdbf0d9d4da8011571.tar.gz
gnu: Add r-zseq.
* gnu/packages/cran.scm (r-zseq): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3ae53a61a1..9d154c030a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20666,3 +20666,27 @@ the posterior distribution in Bayesian statistics are also supplied.")
a @code{zty.pe} game: export R functions as instructions to type to destroy
opponents' vessels.")
(license license:gpl3)))
+
+(define-public r-zseq
+ (package
+ (name "r-zseq")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Zseq" version))
+ (sha256
+ (base32
+ "06dndi2b1q79bmxax11bv0l5ifcz1mhpvbn90y6a6xymrgcq0ivi"))))
+ (properties `((upstream-name . "Zseq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-gmp" ,r-gmp)))
+ (home-page "https://cran.r-project.org/web/packages/Zseq/")
+ (synopsis "Integer sequence generator")
+ (description
+ "This package generates well-known integer sequences. The @code{gmp}
+package is adopted for computing with arbitrarily large numbers. Every
+function has a hyperlink to its corresponding item in the @dfn{On-Line
+Encyclopedia of Integer Sequences} (OEIS) in the function help page.")
+ (license license:gpl3+)))