summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-24 09:44:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-24 09:45:45 +0100
commit08048ce994a52440162c3a5fc9bf3f17c9affa24 (patch)
tree68be493ca474c27ee242e736a1bc3b86ac4e487b /gnu/packages/cran.scm
parent84c86dcebead3b8422bd413fff545e8e76b3f3e6 (diff)
downloadguix-patches-08048ce994a52440162c3a5fc9bf3f17c9affa24.tar
guix-patches-08048ce994a52440162c3a5fc9bf3f17c9affa24.tar.gz
gnu: Add r-iheatmapr.
* gnu/packages/cran.scm (r-iheatmapr): New variable. Co-authored-by: Marcel Schilling <marcel.schilling@mdc-berlin.de>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 60947c5f3f..67f14a3b88 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20200,3 +20200,41 @@ methods (MM, MS, Stocking-Lord, and the complete Hebaera method), and a rich
array of parametric and non-parametric (kernel) plots. It estimates and plots
Haberman's interaction model when all items are dichotomously scored.")
(license license:gpl2+)))
+
+(define-public r-iheatmapr
+ (package
+ (name "r-iheatmapr")
+ (version "0.4.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "iheatmapr" version))
+ (sha256
+ (base32
+ "0s479j9l35xiss599vablxgvg6i2j9zq9sxphsq4vdk3bafg84bw"))))
+ (properties `((upstream-name . "iheatmapr")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fastcluster" ,r-fastcluster)
+ ("r-ggdendro" ,r-ggdendro)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-knitr" ,r-knitr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-plyr" ,r-plyr)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-scales" ,r-scales)))
+ (home-page "https://docs.ropensci.org/iheatmapr")
+ (synopsis "Interactive, Complex Heatmaps")
+ (description
+ "iheatmapr is an R package for building complex, interactive heatmaps
+using modular building blocks. \"Complex\" heatmaps are heatmaps in which
+subplots along the rows or columns of the main heatmap add more information
+about each row or column. For example, a one column additional heatmap may
+indicate what group a particular row or column belongs to. Complex heatmaps
+may also include multiple side by side heatmaps which show different types of
+data for the same conditions. Interactivity can improve complex heatmaps by
+providing tooltips with information about each cell and enabling zooming into
+interesting features. iheatmapr uses the plotly library for interactivity.")
+ (license license:expat)))