summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorRaghav Gururajan via Guix-patches via <guix-patches@gnu.org>2021-12-09 08:45:46 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-14 09:51:09 +0100
commitfd58aa0784273a8148ffd6d3c072156c3161d7f5 (patch)
tree5dc8b172eab0234a315f702cc51c66b3ec3827e0 /gnu/packages/cpp.scm
parent990d0edd0a809dbdb5c3b13a19a5950b8a80c0eb (diff)
downloadguix-patches-fd58aa0784273a8148ffd6d3c072156c3161d7f5.tar
guix-patches-fd58aa0784273a8148ffd6d3c072156c3161d7f5.tar.gz
gnu: Add argagg.
* gnu/packages/cpp.scm (argagg): New variable. Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Julien Lepiller <julien@lepiller.eu> Co-authored-by: Disseminate Dissent <disseminatedissent@protonmail.com> Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 3ba96e99a2..1bae2966b9 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -81,6 +81,45 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xml))
+(define-public argagg
+ (let ((commit "79e4adfa2c6e2bfbe63da05cc668eb9ad5596748") (revision "0"))
+ (package
+ (name "argagg")
+ (version (git-version "0.4.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vietjtnguyen/argagg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1flkgh524lq3024p7ld5lg743s1v7qnbmgv77578rzmn2rjzr77n"))))
+ (build-system cmake-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((name ,(package-name argagg)) (out (assoc-ref
+ outputs
+ "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share/doc"))
+ (rename-file
+ (string-append out "/share/doc/" name)
+ (string-append doc "/share/doc/" name))))))))
+ (native-inputs (list doxygen))
+ (home-page "https://github.com/vietjtnguyen/argagg")
+ (synopsis "C++11 command line argument parser")
+ (description
+ "ArgAgg is yet another C++ command line argument/option
+parser. It was written as a simple and idiomatic alternative to other
+frameworks like getopt, Boost program options, TCLAP, and others. The goal is
+to achieve the majority of argument parsing needs in a simple manner with an
+easy to use API.")
+ (license license:expat))))
+
(define-public asmjit
(let ((commit "4ec760a3d1f69e32ba460ecd2513f29b8428700b")
(revision "0"))