summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-07 02:34:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-07 18:36:02 +0200
commite8211364745ddecef19134bdd7c593401d24b732 (patch)
treec7708048de1feed129af7117c968d1e796ce06b7 /gnu/packages/cpp.scm
parentc83aa2927058fcd28d1a9abc8298a185d77675d3 (diff)
downloadguix-patches-e8211364745ddecef19134bdd7c593401d24b732.tar
guix-patches-e8211364745ddecef19134bdd7c593401d24b732.tar.gz
gnu: xsimd: Don't use unstable tarball.
* gnu/packages/cpp.scm (xsimd)[source]: Use GIT-FETCH and GIT-FILE-NAME. [home-page]: Move down to its conventional spot.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 9c060c70da..1adc2e5855 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -131,21 +131,21 @@ combination of these streams.")
(package
(name "xsimd")
(version "4.1.2")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/QuantStack/xsimd/archive/"
- version ".tar.gz"))
- (sha256
- (base32
- "0x05l4xpqr9b66sm6lkf48n6x7999ks921x6k2hzkkg6mh3gqd46"))
- (file-name (string-append name "-" version ".tar.gz"))))
- (home-page "https://github.com/QuantStack/xsimd")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/QuantStack/xsimd.git")
+ (commit version)))
+ (sha256
+ (base32 "0x86p2xjlaqyfissf30smj1szm4i3iw1x72qnj5dwvfgf7049xds"))
+ (file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
`(#:test-target "xtest"))
(native-inputs
`(("googletest" ,googletest)))
+ (home-page "https://github.com/QuantStack/xsimd")
(synopsis "C++ wrappers for SIMD intrinsics and math implementations")
(description "xsimd provides a unified means for using SIMD features for
library authors. Namely, it enables manipulation of batches of numbers with