summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-11-14 14:48:08 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-02 15:38:17 +0100
commitdf4f960cb8ef43ba49345f26df266683beca2bbf (patch)
tree075662cae15d2e484a51048171d4d2c4d0a0e4f8 /gnu/packages/cpp.scm
parent2d92b3bbb6ac5917ea610f8341b78d026bf74aaf (diff)
downloadguix-patches-df4f960cb8ef43ba49345f26df266683beca2bbf.tar
guix-patches-df4f960cb8ef43ba49345f26df266683beca2bbf.tar.gz
gnu: Add libconfini.
* gnu/packages/cpp.scm (libconfini): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 5af0979e22..9ab6e0b835 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1144,6 +1144,36 @@ output randomness while retaining speed, simplicity, and conciseness.")
(home-page "https://www.pcg-random.org")
(license (list license:expat license:asl2.0))))) ; dual licensed
+(define-public libconfini
+ (package
+ (name "libconfini")
+ (version "1.16.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/madmurphy/libconfini")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01g8ai2z4fwshk06k824j6ib8nfb3cwxs5kqpqjvv4k5ayzm892h"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _ (invoke "sh" "bootstrap" "--noconfigure"))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://madmurphy.github.io/libconfini/html/index.html")
+ (synopsis "INI file parser")
+ (description "@code{libconfini} is an INI file parser library written in
+C. It focuses on standardization and parsing exactness and is at ease with
+almost every type of file containing key/value pairs.")
+ (license license:gpl3+)))
+
(define-public libcutl
(package
(name "libcutl")