summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-03-03 17:38:28 +0100
committerMathieu Othacehe <othacehe@gnu.org>2022-03-03 17:38:28 +0100
commitc53b317ec2d2f0781fe91f5e19d86d6a77f08252 (patch)
tree7122bbedf81092c6b1aa43f42948eb96d3ca1317 /gnu/packages/cpp.scm
parent89f17efbb38acf0054d7e33704cd32a5ecb53839 (diff)
downloadguix-patches-c53b317ec2d2f0781fe91f5e19d86d6a77f08252.tar
guix-patches-c53b317ec2d2f0781fe91f5e19d86d6a77f08252.tar.gz
gnu: Add gulrak-filesystem.
* gnu/packages/cpp.scm (gulrak-filesystem): New variable.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index de6b529302..06d22088f6 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018, 2021 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019, 2020, 2022 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2020, 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
@@ -1721,3 +1721,24 @@ concepts (like dates and times), and building blocks for developing
multi-threaded applications and network applications.")
(home-page "https://github.com/bloomberg/bde")
(license license:asl2.0))))
+
+(define-public gulrak-filesystem
+ (package
+ (name "gulrak-filesystem")
+ (version "1.5.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gulrak/filesystem")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dx1yvbz5rnisymkqap7z0b06ag9fcs6q6l82vgi8caylhkwsqs7"))))
+ (build-system cmake-build-system)
+ (synopsis "Header only C++ std::filesystem compatible library")
+ (description "This package provides a header-only single-file
+std::filesystem compatible helper library, based on the C++17 and C++20 specs,
+but implemented for C++11, C++14, C++17 or C++20.")
+ (home-page "https://github.com/gulrak/filesystem")
+ (license license:expat)))