summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-03-31 12:58:48 +0530
committerEfraim Flashner <efraim@flashner.co.il>2022-03-31 16:14:53 +0300
commit8524904e082464b7eb0c10037613b73da4d4df5e (patch)
tree02cbd36b06f799dc93454441beb0b46cc8807869 /gnu/packages/cpp.scm
parenta83918837e6fb47a4a0c93fea598013b73cd71b8 (diff)
downloadguix-patches-8524904e082464b7eb0c10037613b73da4d4df5e.tar
guix-patches-8524904e082464b7eb0c10037613b73da4d4df5e.tar.gz
gnu: atomic-queue: Do not look for boost when cross-compiling.
* gnu/packages/cpp.scm (atomic-queue)[arguments]: When cross-compiling, add a do-not-check-for-boost phase. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index eb48902034..b0d4fdeb3e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1294,6 +1294,15 @@ provides a number of utilities to make coding with expected cleaner.")
`(#:configure-flags '("-Dbenchmarks=false")
#:phases
(modify-phases %standard-phases
+ ,@(if (%current-target-system)
+ `(;; boost is a test dependency. We don't run tests when
+ ;; cross-compiling. Disable all targets that depend on it.
+ (add-after 'unpack 'do-not-check-for-boost
+ (lambda _
+ (substitute* "meson.build"
+ (("unit_test_framework = [^\n]*" all)
+ "unit_test_framework = disabler()")))))
+ '())
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?