summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-05-28 08:12:05 +0000
committerLudovic Courtès <ludo@gnu.org>2018-05-28 14:19:29 +0200
commit6f3c850618ff67d508addd1394a41401aa3be564 (patch)
treef5dff95576b5bcd11e55b7c048e0a838977dca23 /gnu/packages/cpp.scm
parente3c0676adfb954f58b9237629d82ad2030159f40 (diff)
downloadguix-patches-6f3c850618ff67d508addd1394a41401aa3be564.tar
guix-patches-6f3c850618ff67d508addd1394a41401aa3be564.tar.gz
gnu: Add xtl.
* gnu/packages/cpp.scm (xtl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 4831ab035e..cc5375095b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -238,3 +238,36 @@ as ordering relation.")
(description "JSON for Modern C++ is a C++ JSON library that provides
intutive syntax and trivial integration.")
(license license:expat)))
+
+(define-public xtl
+ (package
+ (name "xtl")
+ (version "0.4.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/QuantStack/xtl/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "05bcz9y590b77bxcip0k31rgsapmkwqi1smvsvc84zz7m87d4jvy"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (native-inputs
+ `(("googletest" ,googletest)
+ ("json-modern-cxx" ,json-modern-cxx)))
+ (arguments
+ `(#:configure-flags
+ '("-DBUILD_TESTS=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* _
+ (with-directory-excursion "test"
+ (invoke "./test_xtl")
+ #t))))))
+ (home-page "https://github.com/QuantStack/xtl")
+ (build-system cmake-build-system)
+ (synopsis "C++ template library providing some basic tools")
+ (description "xtl is a C++ header-only template library providing basic
+tools (containers, algorithms) used by other QuantStack packages.")
+ (license license:bsd-3)))