summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-05-12 15:28:35 +0000
committerLudovic Courtès <ludo@gnu.org>2018-05-24 23:38:48 +0200
commit655ca71329ebdc44d78c3ee1f7b68d29ff6b273b (patch)
tree9a93e74b38b5b05c452be72ea70a3ad0466e17fc /gnu/packages/cpp.scm
parent914205214cd906044411e6438be69c700e355b0d (diff)
downloadguix-patches-655ca71329ebdc44d78c3ee1f7b68d29ff6b273b.tar
guix-patches-655ca71329ebdc44d78c3ee1f7b68d29ff6b273b.tar.gz
gnu: Add xsimd.
* gnu/packages/cpp.scm (xsimd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 3e9c39df61..80ffc1ea2c 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -124,3 +124,30 @@ unified access to TCP/UDP sockets, serial ports, console, and files streams.
It also allows a server application to wait for any activity on any
combination of these streams.")
(license license:bsd-3)))
+
+(define-public xsimd
+ (package
+ (name "xsimd")
+ (version "4.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/QuantStack/xsimd/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0x05l4xpqr9b66sm6lkf48n6x7999ks921x6k2hzkkg6mh3gqd46"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (home-page "https://github.com/QuantStack/xsimd")
+ (build-system cmake-build-system)
+ (arguments
+ `(#:test-target "xtest"))
+ (native-inputs
+ `(("googletest" ,googletest)))
+ (synopsis "C++ wrappers for SIMD intrinsics and math implementations")
+ (description "xsimd provides a unified means for using SIMD features for
+library authors. Namely, it enables manipulation of batches of numbers with
+the same arithmetic operators as for single values. It also provides
+accelerated implementation of common mathematical functions operating on
+batches.")
+ (license license:bsd-3)))