summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-04-30 14:06:34 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:59 +0200
commit5ed42eb9a01e63c25d6c0836b6a1b15e8d5fbd74 (patch)
treeac52dca1fbb85e34cd2745a06bd57a5b073203a3 /gnu/packages/cpp.scm
parent2a0fcc31f723e20fd81eb3c6263c1bdad56f797f (diff)
downloadguix-patches-5ed42eb9a01e63c25d6c0836b6a1b15e8d5fbd74.tar
guix-patches-5ed42eb9a01e63c25d6c0836b6a1b15e8d5fbd74.tar.gz
gnu: Add aws-crt-cpp.
* gnu/packages/cpp.scm (aws-crt-cpp): New variable. * gnu/packages/patches/aws-crt-cpp-cmake-prefix.patch, gnu/packages/patches/aws-crt-cpp-disable-networking-tests.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 469af4a338..383c9843ca 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -881,6 +881,45 @@ of C++14 components that complements @code{std} and Boost.")
(supported-systems '("aarch64-linux" "x86_64-linux"))
(license license:asl2.0)))
+(define-public aws-crt-cpp
+ (let* ((commit "c2d6ffa5597825111cc76ad71ffc6aef664d0f25")
+ (revision "1"))
+ (package
+ (name "aws-crt-cpp")
+ (version (git-version "0.14.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/awslabs/aws-crt-cpp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l7iwynk2rgzjnr1hi1raazghmk4m7pj47vdq2kf2cfz0b6v9jf5"))
+ (patches
+ (search-patches
+ "aws-crt-cpp-cmake-prefix.patch"
+ "aws-crt-cpp-disable-networking-tests.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON"
+ "-DBUILD_DEPS=OFF")))
+ (propagated-inputs
+ `(("aws-c-auth" ,aws-c-auth)
+ ("aws-c-cal" ,aws-c-cal)
+ ("aws-c-event-stream" ,aws-c-event-stream)
+ ("aws-c-http" ,aws-c-http)
+ ("aws-c-mqtt" ,aws-c-mqtt)
+ ("aws-c-s3" ,aws-c-s3)))
+ (synopsis "C++ wrapper for Amazon Web Services C libraries")
+ (description "The AWS Common Runtime (CRT) library provides a C++ wrapper
+implementation for the following @acronym{AWS,Amazon Web Services} C libraries:
+aws-c-auth, aws-c-cal, aws-c-common, aws-c-compression, aws-c-event-stream,
+aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
+ (home-page "https://github.com/awslabs/aws-crt-cpp")
+ (license license:asl2.0))))
+
(define-public aws-sdk-cpp
(package
(name "aws-sdk-cpp")