summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-09-27 14:20:03 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-14 15:44:51 +0200
commit37c88eca5c88ce72fb164f8a8722cc0483736945 (patch)
tree1543cb1c72049461a12d868f8a6ceb256fc1997c /gnu/packages/cpp.scm
parente2a021a745d5009f2e8386108840146faa33fd86 (diff)
downloadguix-patches-37c88eca5c88ce72fb164f8a8722cc0483736945.tar
guix-patches-37c88eca5c88ce72fb164f8a8722cc0483736945.tar.gz
gnu: Add simdjson.
* gnu/packages/cpp.scm (simdjson): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 104fe81e18..469af4a338 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1309,3 +1309,29 @@ of reading and writing XML.")
(description "Jsonnet is a templating language extending JSON
syntax with variables, conditions, functions and more.")
(license license:asl2.0)))
+
+(define-public simdjson
+ (package
+ (name "simdjson")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/simdjson/simdjson")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08qpsw0i8481xlyyghzyszb1vh4c8i7krzzghvr9m4yg394vf6zn"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; tests require downloading dependencies
+ #:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (synopsis "JSON parser for C++ using SIMD instructions")
+ (description
+ "The simdjson library uses commonly available SIMD instructions and
+microparallel algorithms to implement a strict JSON parser with UTF-8
+validation.")
+ (home-page "https://github.com/simdjson/simdjson")
+ (license license:asl2.0)))