summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-12-16 14:05:17 -0600
committerBrett Gilio <brettg@posteo.net>2019-12-16 14:05:17 -0600
commit1171c4b3c03399061b786c24a239ff69cb00eeea (patch)
treedb72f747fcf4b2205883a688b306efb953ad7237 /gnu/packages/cpp.scm
parent792c3db553a02714f32fdfad639c6e168b30033b (diff)
downloadguix-patches-1171c4b3c03399061b786c24a239ff69cb00eeea.tar
guix-patches-1171c4b3c03399061b786c24a239ff69cb00eeea.tar.gz
Revert "gnu: ccls: Configure using -isystem for header files."
This reverts commit 2c82d4ad10de8e0ba462d81401385c5e7499f6e2.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm18
1 files changed, 5 insertions, 13 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 7870184a52..335f9a65cd 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -6,7 +6,6 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
-;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,9 +35,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
- #:use-module (gnu packages gcc)
#:use-module (gnu packages llvm)
- #:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
@@ -308,17 +305,12 @@ tools (containers, algorithms) used by other QuantStack packages.")
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; no check target.
- #:configure-flags
- (list (string-append "-DCMAKE_CXX_FLAGS='-isystem "
- (assoc-ref %build-inputs "gcc")
- "/include/c++'"))))
- (inputs
- `(("clang" ,clang)
- ("ncurses" ,ncurses)))
+ '(#:tests? #f)) ; no check target.
+ (inputs
+ `(("rapidjson" ,rapidjson)))
(native-inputs
- `(("rapidjson" ,rapidjson)
- ("gcc" ,gcc)))
+ `(("clang" ,clang)
+ ("llvm" ,llvm)))
(home-page "https://github.com/MaskRay/ccls")
(synopsis "C/C++/Objective-C language server")
(description