summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-08-18 15:30:23 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-08-18 19:48:18 -0400
commit0bb41aec990832e8b022f7fbcd9586a39f39f9b4 (patch)
tree76ba178c0fafd5db556ef30404487beab519cbcf /gnu/packages/cpp.scm
parent50dbd26ce0a25861cfb428144cc7c21e1cae7f5d (diff)
downloadguix-patches-0bb41aec990832e8b022f7fbcd9586a39f39f9b4.tar
guix-patches-0bb41aec990832e8b022f7fbcd9586a39f39f9b4.tar.gz
gnu: xtl: Update to 0.4.14.
* gnu/packages/cpp.scm (xtl): Update to 0.4.14. [source]: Use git-fetch.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index cc5375095b..0160e42f6a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -242,16 +242,17 @@ intutive syntax and trivial integration.")
(define-public xtl
(package
(name "xtl")
- (version "0.4.8")
+ (version "0.4.14")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/QuantStack/xtl/archive/"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/QuantStack/xtl.git")
+ (commit version)))
(sha256
(base32
- "05bcz9y590b77bxcip0k31rgsapmkwqi1smvsvc84zz7m87d4jvy"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "0wwnd9adc1wav2299id17k5fbp0ib5gxkbihlk6jlh3v4i5nz11x"))
+ (file-name (git-file-name name version))))
(native-inputs
`(("googletest" ,googletest)
("json-modern-cxx" ,json-modern-cxx)))