summaryrefslogtreecommitdiff
path: root/gnu/packages/cpio.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-17 22:13:33 -0400
committerMark H Weaver <mhw@netris.org>2015-06-17 23:19:02 -0400
commit9ae1e920718e95577c12de890754b6a6a4ff70a1 (patch)
tree2b10dbbddcf67b0df411a48ce2ce4ecf2da2a9e2 /gnu/packages/cpio.scm
parenta2ee6cbea281ac20fefe948459b85c26010ea578 (diff)
downloadguix-patches-9ae1e920718e95577c12de890754b6a6a4ff70a1.tar
guix-patches-9ae1e920718e95577c12de890754b6a6a4ff70a1.tar.gz
gnu: cpio: Fix symlink-bad-length test.
* gnu/packages/patches/cpio-fix-symlink-bad-length-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/cpio.scm (cpio): Add patch.
Diffstat (limited to 'gnu/packages/cpio.scm')
-rw-r--r--gnu/packages/cpio.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/cpio.scm b/gnu/packages/cpio.scm
index 87f85d00e8..cfb416239d 100644
--- a/gnu/packages/cpio.scm
+++ b/gnu/packages/cpio.scm
@@ -36,12 +36,14 @@
(sha256
(base32
"1gavgpzqwgkpagjxw72xgxz52y1ifgz0ckqh8g7cckz7jvyhp0mv"))
- (patches (list (search-patch "cpio-CVE-2014-9112-pt1.patch")
- (search-patch "cpio-CVE-2014-9112-pt2.patch")
- (search-patch "cpio-CVE-2014-9112-pt3.patch")
- (search-patch "cpio-CVE-2014-9112-pt4.patch")
- (search-patch "cpio-CVE-2014-9112-pt5.patch")
- (search-patch "cpio-gets-undeclared.patch")))))
+ (patches (map search-patch
+ '("cpio-CVE-2014-9112-pt1.patch"
+ "cpio-CVE-2014-9112-pt2.patch"
+ "cpio-CVE-2014-9112-pt3.patch"
+ "cpio-CVE-2014-9112-pt4.patch"
+ "cpio-CVE-2014-9112-pt5.patch"
+ "cpio-fix-symlink-bad-length-test.patch"
+ "cpio-gets-undeclared.patch")))))
(build-system gnu-build-system)
;; FIXME: autoconf is needed to run autom4te, to update to test suite