summaryrefslogtreecommitdiff
path: root/gnu/packages/cpio.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /gnu/packages/cpio.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
guix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'gnu/packages/cpio.scm')
-rw-r--r--gnu/packages/cpio.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/cpio.scm b/gnu/packages/cpio.scm
new file mode 100644
index 0000000000..6fddc3f768
--- /dev/null
+++ b/gnu/packages/cpio.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cpio)
+ #:use-module (guix licenses)
+ #:use-module (distro)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public cpio
+ (package
+ (name "cpio")
+ (version "2.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/cpio/cpio-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1gavgpzqwgkpagjxw72xgxz52y1ifgz0ckqh8g7cckz7jvyhp0mv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:patches (list (assoc-ref %build-inputs
+ "patch/gets"))))
+ (inputs
+ `(("patch/gets" ,(search-patch "cpio-gets-undeclared.patch"))))
+ (home-page "https://www.gnu.org/software/cpio/")
+ (synopsis
+ "A program to create or extract from cpio archives")
+ (description
+ "GNU Cpio copies files into or out of a cpio or tar archive. The
+archive can be another file on the disk, a magnetic tape, or a pipe.
+
+GNU Cpio supports the following archive formats: binary, old ASCII, new
+ASCII, crc, HPUX binary, HPUX old ASCII, old tar, and POSIX.1 tar. The
+tar format is provided for compatability with the tar program. By
+default, cpio creates binary format archives, for compatibility with
+older cpio programs. When extracting from archives, cpio automatically
+recognizes which kind of archive it is reading and can read archives
+created on machines with a different byte-order.")
+ (license gpl3+))) \ No newline at end of file