summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-05-04 18:23:20 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-05-04 19:41:04 +0200
commite03e1b5584634a850bbad8ad58d1e63f436cedbd (patch)
tree2513dccf36d696259d4011f2d9e78af467999155 /gnu/packages/coq.scm
parent729102cbf4f38e74476a85c6b4934438bae1b416 (diff)
downloadguix-patches-e03e1b5584634a850bbad8ad58d1e63f436cedbd.tar
guix-patches-e03e1b5584634a850bbad8ad58d1e63f436cedbd.tar.gz
gnu: coq: Update to 8.9.0.
* gnu/packages/coq.scm (coq): Update to 8.9.0. (coq-autosubst): Update to latest commit. (coq-equations): Update to 1.2-beta2.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index bdf1576400..2b3803b3d7 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -42,7 +42,7 @@
(define-public coq
(package
(name "coq")
- (version "8.8.2")
+ (version "8.9.0")
(source
(origin
(method git-fetch)
@@ -51,7 +51,7 @@
(commit (string-append "V" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "03v8b57mz3ivsijwxy51avzwiyhla5ijaf98a5a2q29yabdq8dkp"))))
+ (base32 "01ad7az6f95w16xya7979lk32agy22lf4bqgqf5qpnarpkpxhbw8"))))
(native-search-paths
(list (search-path-specification
(variable "COQPATH")
@@ -62,6 +62,8 @@
("python" ,python-2)
("camlp5" ,camlp5)
("ocaml-num" ,ocaml-num)))
+ (native-inputs
+ `(("ocaml-ounit" ,ocaml-ounit)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -450,7 +452,7 @@ Coq proof assistant.")
;; Latest commit on that branch, where work on supporting coq 8.6 and
;; more recent versions of coq happen.
(let ((branch "coq86-devel")
- (commit "d0d73557979796b3d4be7aac72135581c33f26f7"))
+ (commit "fa6ef30664511ffa659cbcf3c962715cbee03572"))
(package
(name "coq-autosubst")
(version (git-version "1" branch commit))
@@ -461,7 +463,7 @@ Coq proof assistant.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1852xb5cwkjw3dlc0lp2sakwa40bjzw37qmwz4bn3vqazg1hnh6r"))))
+ (base32 "1cl0bp96bk6lplbl7n5c703vd3gvbs5mvf2qrf8q333kkqd7jqq4"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f
@@ -495,16 +497,16 @@ uses Ltac to synthesize the substitution operation.")
(define-public coq-equations
(package
(name "coq-equations")
- (version "1.1")
+ (version "1.2-beta2")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/mattam82/Coq-Equations.git")
- (commit (string-append "v" version "-8.8"))))
+ (commit (string-append "v" version "-8.9"))))
(file-name (git-file-name name version))
(sha256
(base32
- "129rxsdsf88vjcw0xhm74yax1hmnk6f8n9ksg0hcyyjq1ijddiwa"))))
+ "0y2zwv7jxs1crprj5qvg46h0v9wyfn99ln40yskq91y9h1lj5h3j"))))
(build-system gnu-build-system)
(native-inputs
`(("ocaml" ,ocaml)