summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 09:24:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:18 +0100
commita48d6acc23f426ca70e190e717a20cdb21df297f (patch)
treed6d2c14663f7c3ceb6cc5eb4ac5125f5081e50be /gnu/packages/coq.scm
parent8543ccf87b9a8664fd02d595e8015c62d0f6841d (diff)
downloadguix-patches-a48d6acc23f426ca70e190e717a20cdb21df297f.tar
guix-patches-a48d6acc23f426ca70e190e717a20cdb21df297f.tar.gz
gnu: proof-general: Use INVOKE.
* gnu/packages/coq.scm (proof-general)[arguments]: Use INVOKE in build phases.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 3a898814c3..97ed33d1ba 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -155,17 +155,16 @@ It is developed using Objective Caml and Camlp5.")
"EMACS=" emacs "/bin/emacs")))
#t)))
(add-after 'unpack 'clean
- (lambda _
- ;; Delete the pre-compiled elc files for Emacs 23.
- (zero? (system* "make" "clean"))))
+ (lambda _
+ ;; Delete the pre-compiled elc files for Emacs 23.
+ (invoke "make" "clean")))
(add-after 'install 'install-doc
- (lambda* (#:key make-flags #:allow-other-keys)
- ;; XXX FIXME avoid building/installing pdf files,
- ;; due to unresolved errors building them.
- (substitute* "Makefile"
- ((" [^ ]*\\.pdf") ""))
- (zero? (apply system* "make" "install-doc"
- make-flags)))))))
+ (lambda* (#:key make-flags #:allow-other-keys)
+ ;; XXX FIXME avoid building/installing pdf files,
+ ;; due to unresolved errors building them.
+ (substitute* "Makefile"
+ ((" [^ ]*\\.pdf") ""))
+ (apply invoke "make" "install-doc" make-flags))))))
(home-page "http://proofgeneral.inf.ed.ac.uk/")
(synopsis "Generic front-end for proof assistants based on Emacs")
(description