summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-06 02:19:57 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-06 21:07:39 -0600
commit8f1216552ceb02e8a16579637041d7b5f1eb96f3 (patch)
treed4a71347666d91cabf02667c90c1f26adad93b48 /gnu/packages/coq.scm
parentc0228096411bb4b81cf1dce6d0ed35a2129270c1 (diff)
downloadguix-patches-8f1216552ceb02e8a16579637041d7b5f1eb96f3.tar
guix-patches-8f1216552ceb02e8a16579637041d7b5f1eb96f3.tar.gz
gnu: coq-interval: Update to 3.4.1.
* gnu/packages/coq.scm (coq-interval): Update to 3.4.1. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake for remake.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 2666b429fe..08e0584e19 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -453,17 +453,22 @@ provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
(define-public coq-interval
(package
(name "coq-interval")
- (version "3.4.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://gforge.inria.fr/frs/download.php/"
- "file/37524/interval-" version ".tar.gz"))
- (sha256
- (base32
- "023j9sd64brqvjdidqkn5m8d7a93zd9r86ggh573z9nkjm2m7vvg"))))
+ (version "3.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/coqinterval/interval.git")
+ (commit (string-append "interval-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03q3dfqi3r3f7aji5s06ig4aav9ajcwswwdzi5lrgr69z0m487k4"))))
(build-system gnu-build-system)
(native-inputs
- `(("ocaml" ,ocaml)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("ocaml" ,ocaml)
("which" ,which)
("coq" ,coq)))
(propagated-inputs