summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-24 23:57:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-25 14:08:31 +0200
commit775373b872df7b2e00232e72715dda0ada89e876 (patch)
tree088ff4a51ae8cf1845cc2f956d5f91a168c232a7 /gnu/packages/coq.scm
parent8b1fd3cafd9c3040d098ff538a233bf7dc43b397 (diff)
downloadguix-patches-775373b872df7b2e00232e72715dda0ada89e876.tar
guix-patches-775373b872df7b2e00232e72715dda0ada89e876.tar.gz
gnu: coq-bignums: Don't use unstable tarball.
* gnu/pacakges/coq.scm (coq-bignums)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 2c5674f57a..75b9831d39 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -377,13 +377,14 @@ theorems between the two libraries.")
(name "coq-bignums")
(version "8.9.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/coq/bignums/archive/V"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coq/bignums.git")
+ (commit (string-append "V" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0pmk9smw7a14wrfkvjlvmpxim4bsv6xnm5xkrlld2faqy74a044g"))))
+ "03qz1w2xb2j5p06liz5yyafl0fl9vprcqm6j0iwi7rxwghl00p01"))))
(build-system gnu-build-system)
(native-inputs
`(("ocaml" ,ocaml)