summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 11:43:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:19 +0100
commit7492af9be7ba33d94f5784b9eaf3ebeea487e64a (patch)
treea41acbe6c9438f7c42d7d64e678a01991463e01e /gnu/packages/coq.scm
parente09e83880f0ad1901011ae516db59495fe582caa (diff)
downloadguix-patches-7492af9be7ba33d94f5784b9eaf3ebeea487e64a.tar
guix-patches-7492af9be7ba33d94f5784b9eaf3ebeea487e64a.tar.gz
gnu: coq-interval: Use INVOKE.
* gnu/packages/coq.scm (coq-interval)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index f4d7cc2b79..51dd5dedcf 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -430,16 +430,14 @@ provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
(add-before 'configure 'fix-remake
(lambda _
(substitute* "remake.cpp"
- (("/bin/sh") (which "sh")))))
+ (("/bin/sh") (which "sh")))
+ #t))
(replace 'build
- (lambda _
- (zero? (system* "./remake"))))
+ (lambda _ (invoke "./remake")))
(replace 'check
- (lambda _
- (zero? (system* "./remake" "check"))))
+ (lambda _ (invoke "./remake" "check")))
(replace 'install
- (lambda _
- (zero? (system* "./remake" "install")))))))
+ (lambda _ (invoke "./remake" "install"))))))
(home-page "http://coq-interval.gforge.inria.fr/")
(synopsis "Coq tactics to simplify inequality proofs")
(description "Interval provides vernacular files containing tactics for