summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-06 01:35:55 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-06 21:04:20 -0600
commit346825571cd37782a880e17fbb76afc2f14d4959 (patch)
treeabfcf94ab0ec76ea5dcf2420249faa4c57380416 /gnu/packages/coq.scm
parenta5727da96aa131604fe1552b8938e3a2998b2745 (diff)
downloadguix-patches-346825571cd37782a880e17fbb76afc2f14d4959.tar
guix-patches-346825571cd37782a880e17fbb76afc2f14d4959.tar.gz
gnu: coq-flocq: Update to 3.2.0.
* gnu/packages/coq.scm (coq-flocq): Update to 3.2.0. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake for remake. [arguments]: Add remove-failing-examples phase to work around union error.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm31
1 files changed, 21 insertions, 10 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 89b1c2149b..ff6a436b94 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -21,6 +21,7 @@
(define-module (gnu packages coq)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
@@ -207,18 +208,22 @@ provers.")
(define-public coq-flocq
(package
(name "coq-flocq")
- (version "3.1.0")
- (source (origin
- (method url-fetch)
- ;; Use the ‘Latest version’ link for a stable URI across releases.
- (uri (string-append "https://gforge.inria.fr/frs/download.php/"
- "file/37901/flocq-" version ".tar.gz"))
- (sha256
- (base32
- "02szrgz9m0ac51la1lqpiv6i2g0zbgx9gz5rp0q1g00ajldyna5c"))))
+ (version "3.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/flocq/flocq.git")
+ (commit (string-append "flocq-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15bi36x7zj0glsb3s2gwqd4wswhfzh36rbp7imbyff53a7nna95l"))))
(build-system gnu-build-system)
(native-inputs
- `(("ocaml" ,ocaml)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("ocaml" ,ocaml)
("which" ,which)
("coq" ,coq)))
(arguments
@@ -227,6 +232,12 @@ provers.")
"/lib/coq/user-contrib/Flocq"))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-examples
+ (lambda _
+ (substitute* "Remakefile.in"
+ ;; Fails on a union error.
+ (("Double_rounding_odd_radix.v") ""))
+ #t))
(add-before 'configure 'fix-remake
(lambda _
(substitute* "remake.cpp"