summaryrefslogtreecommitdiff
path: root/gnu/packages/cook.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 21:21:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-21 15:02:47 +0100
commitea5d238dae574d08bd25ecc6c1fb3bf009707257 (patch)
tree531edda1def7e2ca79088bc329e35fbaab6f5d75 /gnu/packages/cook.scm
parent61faf24df66bdade0ec780d4a5e5e3d461329341 (diff)
downloadguix-patches-ea5d238dae574d08bd25ecc6c1fb3bf009707257.tar
guix-patches-ea5d238dae574d08bd25ecc6c1fb3bf009707257.tar.gz
gnu: cook: Update phase style.
* gnu/packages/cook.scm (cook)[arguments]: Use MODIFY-PHASES syntax and end phase with #t.
Diffstat (limited to 'gnu/packages/cook.scm')
-rw-r--r--gnu/packages/cook.scm37
1 files changed, 19 insertions, 18 deletions
diff --git a/gnu/packages/cook.scm b/gnu/packages/cook.scm
index e149968f24..17e090d725 100644
--- a/gnu/packages/cook.scm
+++ b/gnu/packages/cook.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,26 +42,26 @@
(arguments
`(#:parallel-build? #f ; There are some nasty racy rules in the Makefile.
#:phases
- (alist-cons-before
- 'configure 'pre-conf
- (lambda _
- (substitute* (append '("common/env.c")
- (find-files "test" "\\.sh"))
- (("/bin/sh") (which "sh")))
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-conf
+ (lambda _
+ (substitute* (append '("common/env.c")
+ (find-files "test" "\\.sh"))
+ (("/bin/sh") (which "sh")))
- ;; Guix's binutils (because it wants bit-reproducable builds) is
- ;; is configured with the --enable-deterministic-archives flag.
- ;; This means the timestamp of files appended to an ar archive
- ;; are automatically and silently mutated to 00:00 1 Jan 1970
- ;; which plays havoc with this test, for which correct timestamps
- ;; are very important. Adding the U flag undoes the effect of
- ;; --enable-deterministic-archives and allows this test to work
- ;; again.
- (substitute* "test/00/t0077a.sh"
- (("ar qc") "ar qcU"))
+ ;; Guix's binutils (because it wants bit-reproducable builds) is
+ ;; is configured with the --enable-deterministic-archives flag.
+ ;; This means the timestamp of files appended to an ar archive
+ ;; are automatically and silently mutated to 00:00 1 Jan 1970
+ ;; which plays havoc with this test, for which correct timestamps
+ ;; are very important. Adding the U flag undoes the effect of
+ ;; --enable-deterministic-archives and allows this test to work
+ ;; again.
+ (substitute* "test/00/t0077a.sh"
+ (("ar qc") "ar qcU"))
- (setenv "SH" (which "sh")))
- %standard-phases)))
+ (setenv "SH" (which "sh"))
+ #t)))))
(native-inputs `(("bison" ,bison)
;; For building the documentation:
("groff" ,groff)