summaryrefslogtreecommitdiff
path: root/gnu/packages/containers.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-10 09:06:07 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-11 20:17:50 +0000
commit64c0bc0252d7e91c0ce08a0b90fe5a7244fa904c (patch)
tree0da7b1a6146a1d70b8ebcaf95874256cf6cfe9f8 /gnu/packages/containers.scm
parent1516e1d884810e1007ee84ec45f2d4d32cdfc040 (diff)
downloadguix-patches-64c0bc0252d7e91c0ce08a0b90fe5a7244fa904c.tar
guix-patches-64c0bc0252d7e91c0ce08a0b90fe5a7244fa904c.tar.gz
gnu: conmon: Use G-expressions.
* gnu/packages/containers.scm (conmon)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/containers.scm')
-rw-r--r--gnu/packages/containers.scm32
1 files changed, 18 insertions, 14 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 9510e71349..c978be75ff 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Timmy Douglas <mail@timmydouglas.com>
+;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17,6 +18,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages containers)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (guix packages)
@@ -117,20 +119,22 @@ Container Runtime fully written in C.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
- (string-append "PREFIX=" %output))
- ;; XXX: uses `go get` to download 50 packages, runs a ginkgo test suite
- ;; then tries to download busybox and use a systemd logging library
- ;; see also https://github.com/containers/conmon/blob/main/nix/derivation.nix
- #:tests? #f
- #:test-target "test"
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'set-env
- (lambda* (#:key inputs #:allow-other-keys)
- ;; when running go, things fail because
- ;; HOME=/homeless-shelter.
- (setenv "HOME" "/tmp"))))))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ ;; XXX: uses `go get` to download 50 packages, runs a ginkgo test suite
+ ;; then tries to download busybox and use a systemd logging library
+ ;; see also https://github.com/containers/conmon/blob/main/nix/derivation.nix
+ #:tests? #f
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'set-env
+ (lambda _
+ ;; when running go, things fail because
+ ;; HOME=/homeless-shelter.
+ (setenv "HOME" "/tmp"))))))
(inputs
(list crun
glib