summaryrefslogtreecommitdiff
path: root/gnu/packages/connman.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-25 19:01:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-25 19:02:35 +0200
commitbf9dc7568272e28b79dd1ae3610c3ac83cc216a6 (patch)
tree2d1051f00ff154c6e80398fdb47b3fa44a1b7205 /gnu/packages/connman.scm
parent7f86f4267189ee12ccdff598ef84bf90a81a9b5c (diff)
downloadguix-patches-bf9dc7568272e28b79dd1ae3610c3ac83cc216a6.tar
guix-patches-bf9dc7568272e28b79dd1ae3610c3ac83cc216a6.tar.gz
gnu: connman: Update to 1.40.
* gnu/packages/connman.scm (connman): Update to 1.40. [source]: Remove upstreamed patch. [inputs]: Add lz4, rather than propagate it from openconnect. * gnu/packages/patches/connman-CVE-2021-33833.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/connman.scm')
-rw-r--r--gnu/packages/connman.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/connman.scm b/gnu/packages/connman.scm
index ac3e7422e8..7268af4c8b 100644
--- a/gnu/packages/connman.scm
+++ b/gnu/packages/connman.scm
@@ -28,6 +28,7 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages enlightenment)
#:use-module (gnu packages glib)
#:use-module (gnu packages linux)
@@ -44,15 +45,14 @@
(define-public connman
(package
(name "connman")
- (version "1.39")
+ (version "1.40")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/network/connman/"
"connman-" version ".tar.xz"))
- (patches (search-patches "connman-CVE-2021-33833.patch"))
(sha256
- (base32 "1wqs307vjphhh73qbqk25zxhhqwn1mdk6bpzl5qcd4blkcbafqlz"))))
+ (base32 "04nbxpaxykncp65fyh4lk778vn9145fbxhxa8hbkmailw9yawmqs"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -76,6 +76,7 @@
("gnutls" ,gnutls)
("iptables" ,iptables)
("libmnl" ,libmnl)
+ ("lz4" ,lz4) ; required by openconnect.pc
("readline" ,readline)
;; These inputs are needed for connman to include the interface to
;; these technologies so IF they are installed they can be used.