summaryrefslogtreecommitdiff
path: root/gnu/packages/connman.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-21 22:54:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-12-04 08:39:49 +0200
commit8c1585171700b4f0ada0a3030b79b63ea14f9c17 (patch)
tree4471adc5d71c8321e0da6249cc41f3ca0ae773db /gnu/packages/connman.scm
parent22fda787f679c5ff02b6d027db663b7964786fff (diff)
downloadguix-patches-8c1585171700b4f0ada0a3030b79b63ea14f9c17.tar
guix-patches-8c1585171700b4f0ada0a3030b79b63ea14f9c17.tar.gz
gnu: Add econnman.
* gnu/packages/connman.scm (econnman): New variable.
Diffstat (limited to 'gnu/packages/connman.scm')
-rw-r--r--gnu/packages/connman.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/connman.scm b/gnu/packages/connman.scm
index 65214271b5..6b061db58a 100644
--- a/gnu/packages/connman.scm
+++ b/gnu/packages/connman.scm
@@ -24,6 +24,7 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages enlightenment)
#:use-module (gnu packages glib)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
@@ -90,3 +91,38 @@ cases. Connman implements DNS resolving and caching, DHCP clients for both
IPv4 and IPv6, link-local IPv4 address handling and tethering (IP connection
sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
(license gpl2)))
+
+(define-public econnman
+ (package
+ (name "econnman")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.enlightenment.org/rel/apps/"
+ "econnman/econnman-" version ".tar.gz"))
+ (sha256
+ (base32
+ "057pwwavlvrrq26bncqnfrf449zzaim0zq717xv86av4n940gwv0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--localstatedir=/var")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-binary
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/econnman-bin")))
+ (wrap-program bin
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))
+ #t))))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("efl" ,efl)
+ ("python-2" ,python-2)
+ ("python2-efl" ,python2-efl)))
+ (home-page "https://www.enlightenment.org")
+ (synopsis "Connman User Interface written using the EFL")
+ (description
+ "An EFL user interface for the @code{connman} connection manager.")
+ (license lgpl3)))