summaryrefslogtreecommitdiff
path: root/gnu/packages/connman.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/connman.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/connman.scm')
-rw-r--r--gnu/packages/connman.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/connman.scm b/gnu/packages/connman.scm
index 85536f933b..f2ebfc95eb 100644
--- a/gnu/packages/connman.scm
+++ b/gnu/packages/connman.scm
@@ -71,22 +71,22 @@
`(("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
- `(("dbus" ,dbus)
- ("glib" ,glib)
- ("gnutls" ,gnutls)
- ("iptables" ,iptables)
- ("libmnl" ,libmnl)
- ("lz4" ,lz4) ; required by openconnect.pc
- ("readline" ,readline)
- ;; These inputs are needed for connman to include the interface to
- ;; these technologies so IF they are installed they can be used.
- ;; TODO: add neard, ofono
- ("openconnect" ,openconnect)
- ("openvpn" ,openvpn)
- ("ppp" ,ppp)
- ("vpnc" ,vpnc)
- ("wpa-supplicant" ,wpa-supplicant)
- ("xl2tpd" ,xl2tpd)))
+ (list dbus
+ glib
+ gnutls
+ iptables
+ libmnl
+ lz4 ; required by openconnect.pc
+ readline
+ ;; These inputs are needed for connman to include the interface to
+ ;; these technologies so IF they are installed they can be used.
+ ;; TODO: add neard, ofono
+ openconnect
+ openvpn
+ ppp
+ vpnc
+ wpa-supplicant
+ xl2tpd))
(home-page "https://01.org/connman")
(synopsis "Connection management daemon")
(description "Connman provides a daemon for managing Internet connections.
@@ -125,7 +125,7 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
(wrap-program bin
`("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))))
#t))))))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
(inputs
`(("efl" ,efl)
("python" ,python-wrapper)
@@ -150,9 +150,9 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
(sha256
(base32 "0jn12wxwjznady6aniwmvahg1dj25p902sdwj0070biv6vx5c7dq"))))
(inputs
- `(("qtbase" ,qtbase-5)))
+ (list qtbase-5))
(native-inputs
- `(("qttools" ,qttools)))
+ (list qttools))
(build-system gnu-build-system)
(arguments
'(#:phases