summaryrefslogtreecommitdiff
path: root/gnu/packages/conky.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-06 23:55:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-06 23:55:31 +0200
commit4002fcfb8b79095664ee4f5a77ee2629142b5482 (patch)
tree10a2f6e034a1022d2d439a0587f6634fb4308e09 /gnu/packages/conky.scm
parentdfef3121c35aa7d42324afa106cd9b1579f14153 (diff)
downloadguix-patches-4002fcfb8b79095664ee4f5a77ee2629142b5482.tar
guix-patches-4002fcfb8b79095664ee4f5a77ee2629142b5482.tar.gz
gnu: conky: Run tests.
There were always tests. * gnu/packages/conky.scm (conky)[arguments]: Build and run tests.
Diffstat (limited to 'gnu/packages/conky.scm')
-rw-r--r--gnu/packages/conky.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/conky.scm b/gnu/packages/conky.scm
index 2c3cb87002..a1edc93d15 100644
--- a/gnu/packages/conky.scm
+++ b/gnu/packages/conky.scm
@@ -51,10 +51,10 @@
(base32 "1grxapl4q37fzk2rsijwz2rrl0aj520y8daki6bg48jb9vjd39n7"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; there are no tests
- #:configure-flags
+ `(#:configure-flags
(list "-DRELEASE=true"
- "-DBUILD_PULSEAUDIO=ON")
+ "-DBUILD_PULSEAUDIO=ON"
+ "-DBUILD_TESTS=ON")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'add-freetype-to-search-path