summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-31 00:41:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-08-22 15:37:47 +0200
commitf5111b4d2b982d58387188bc3018e4dd2e9a9d4f (patch)
tree20e6f4603e719745917d861730ec571b80bcaaf4 /gnu/packages/compression.scm
parentff452beac5dd7ffecc39556083c94435570d9c1d (diff)
downloadguix-patches-f5111b4d2b982d58387188bc3018e4dd2e9a9d4f.tar
guix-patches-f5111b4d2b982d58387188bc3018e4dd2e9a9d4f.tar.gz
gnu: Add zutils.
* gnu/packages/compression.scm (zutils): New public variable.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 9834fcbe63..bda43bfd18 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1954,3 +1954,49 @@ reading from and writing to ZIP archives. ")
;; Project is distributed under LGPL, but "quazip/z*" "quazip/unzip.*" are
;; distributed under zlib terms.
(license (list license:lgpl2.1+ license:zlib))))
+
+(define-public zutils
+ (package
+ (name "zutils")
+ ;; Check and remove the lint-hidden-cve property when updating.
+ (version "1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/zutils/zutils-" version ".tar.lz"))
+ (sha256
+ (base32 "0dx35mv78fgqgz6sszs05ng8ipz2xy09ry9vpmka2rmy08b7x907"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--sysconfdir=/etc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (apply invoke "make" "install"
+ (string-append "sysconfdir=" (assoc-ref outputs "out")
+ "/etc")
+ make-flags))))))
+ (native-inputs
+ ;; Needed to extract the source tarball and run the test suite.
+ `(("lzip" ,lzip)))
+ (properties `((lint-hidden-cve . ("CVE-2018-1000637"))))
+ (home-page "https://www.nongnu.org/zutils/zutils.html")
+ (synopsis "Utilities that transparently operate on compressed files")
+ (description
+ "Zutils is a collection of utilities able to process any combination of
+compressed and uncompressed files transparently. If any given file, including
+standard input, is compressed, its decompressed content is used instead.
+
+@command{zcat}, @command{zcmp}, @command{zdiff}, and @command{zgrep} are
+improved replacements for the shell scripts provided by GNU gzip.
+@command{ztest} tests the integrity of supported compressed files.
+@command{zupdate} recompresses files with lzip, similar to gzip's
+@command{znew}.
+
+Supported compression formats are bzip2, gzip, lzip, and xz. Zutils uses
+external compressors: the compressor to be used for each format is configurable
+at run time, and must be installed separately.")
+ (license (list license:bsd-2 ; arg_parser.{cc,h}
+ license:gpl2+)))) ; the rest