summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-28 00:34:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-28 00:34:13 +0200
commite0b9e377f1822be434dc9eba516972979485694b (patch)
treebab3137a98d00f308a401095074829303f067059 /gnu/packages/compression.scm
parent201c0e72768fa92e2035512e16c17c07f308815b (diff)
parentfb2715720adfb770bccd37dd72b2bf1b0bc22e36 (diff)
downloadguix-patches-e0b9e377f1822be434dc9eba516972979485694b.tar
guix-patches-e0b9e377f1822be434dc9eba516972979485694b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 6ed4519344..7237931b7d 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -474,6 +474,36 @@ more than bzip2, which makes it well suited for software distribution and data
archiving. Lzip is a clean implementation of the LZMA algorithm.")
(license license:gpl3+)))
+(define-public lziprecover
+ (package
+ (name "lziprecover")
+ (version "1.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/lzip/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0z5fbkm0qprypjf7kxkqganniibj0zml13zvfkrchnjafcmmzyld"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.nongnu.org/lzip/lziprecover.html")
+ (synopsis "Recover and decompress data from damaged lzip files")
+ (description
+ "Lziprecover is a data recovery tool and decompressor for files in the lzip
+compressed data format (.lz). It can test the integrity of lzip files, extract
+data from damaged ones, and repair most files with small errors (up to one
+single-byte error per member) entirely.
+
+Lziprecover is not a replacement for regular backups, but a last line of defence
+when even the backups are corrupt. It can recover files by merging the good
+parts of two or more damaged copies, such as can be easily produced by running
+@command{ddrescue} on a failing device.
+
+This package also includes @command{unzcrash}, a tool to test the robustness of
+decompressors when faced with corrupted input.")
+ (license (list license:bsd-2 ; arg_parser.{cc,h}
+ license:gpl2+)))) ; everything else
+
(define-public sharutils
(package
(name "sharutils")