summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-08 10:46:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-08 10:46:44 +0300
commitde0954d18c70c8959243696d4519c2ac58271ff6 (patch)
tree3a521158c2167c1956a7a10ca7ad5fb3395c2184 /gnu/packages/compression.scm
parentfcd88262dfcbd2e85156f75e786a65b1ab3cc953 (diff)
downloadguix-patches-de0954d18c70c8959243696d4519c2ac58271ff6.tar
guix-patches-de0954d18c70c8959243696d4519c2ac58271ff6.tar.gz
gnu: p7zip: Honor #:tests? flag.
* gnu/packages/compression.scm (p7zip)[arguments]: Only run test suite when #:tests? is true.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 4e6370f8c6..561f134c4c 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1347,10 +1347,11 @@ for most inputs, but the resulting compressed files are anywhere from 20% to
"makefile.linux_any_cpu_gcc_4.X")))
"makefile.machine")))
(replace 'check
- (lambda _
- (invoke "make" "test")
- (invoke "make" "test_7z")
- (invoke "make" "test_7zr"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "test")
+ (invoke "make" "test_7z")
+ (invoke "make" "test_7zr")))))))
(native-inputs
(let ((system (or (%current-target-system)
(%current-system))))