summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-08-01 23:23:32 +0200
committerMarius Bakke <marius@gnu.org>2021-08-01 23:23:32 +0200
commitd2e102d4e4fc5288d93e1100e86b35938a9ac162 (patch)
treeb5ec688c954f7736c17371d9c76ff30509e8e6e8 /gnu/packages/compression.scm
parentb2a5a180cfa56e55bc8078d606a971e34e326967 (diff)
parent536bec1ce5b3d68a6773f31e3788c63e8905ce98 (diff)
downloadguix-patches-d2e102d4e4fc5288d93e1100e86b35938a9ac162.tar
guix-patches-d2e102d4e4fc5288d93e1100e86b35938a9ac162.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index c6ddfb4333..560e9d076a 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2021 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2277,6 +2278,49 @@ reading from and writing to ZIP archives. ")
;; distributed under zlib terms.
(license (list license:lgpl2.1+ license:zlib))))
+(define-public zchunk
+ (package
+ (name "zchunk")
+ (version "1.1.16")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zchunk/zchunk")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nlzwnv6wh2yjyyv27f81jnvmk7psgpbnw7dsdp7frfkya569hgv"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)))
+ (propagated-inputs
+ `(("zstd" ,zstd "lib"))) ;in Requires.private of zck.pc
+ (home-page "https://github.com/zchunk/zchunk")
+ (synopsis "Compressed file format for efficient deltas")
+ (description "The zchunk compressed file format allows splitting a file
+into independent chunks. This makes it possible to retrieve only changed
+chunks when downloading a new version of the file, and also makes zchunk files
+efficient over rsync. Along with the library, this package provides the
+following utilities:
+@table @command
+@item unzck
+To decompress a zchunk file.
+@item zck
+To compress a new zchunk file, or re-compress an existing one.
+@item zck_delta_size
+To calculate the difference between two zchunk files.
+@item zck_gen_zdict
+To create a dictionary for a zchunk file.
+@item zck_read_header
+To read a zchunk header.
+@item zckdl
+To download a zchunk file.
+@end table")
+ (license license:bsd-2)))
+
(define-public zutils
(package
(name "zutils")