summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-12 22:06:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-13 00:32:21 +0200
commitbd1c5fe46bf86363be7278a06490d95709423ad7 (patch)
treecfcb440f4e40d7c3f3045b3cffc2454bcf17231e /gnu/packages/compression.scm
parentc9c274172b781c51e67868c53c8b2ea394bf7a94 (diff)
downloadguix-patches-bd1c5fe46bf86363be7278a06490d95709423ad7.tar
guix-patches-bd1c5fe46bf86363be7278a06490d95709423ad7.tar.gz
gnu: snappy: Update to 1.1.9.
* gnu/packages/compression.scm (snappy): Update to 1.1.9. [source]: Add another patch. [arguments]: Add new #:configure-flags and an 'unpack-third_party-subprojects phase. [native-inputs]: Add the sources for benchmark and googletests. * gnu/packages/patches/snappy-add-inline-for-GCC.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm33
1 files changed, 29 insertions, 4 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 02d2d0a3e6..3dbe517f93 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -66,6 +66,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
+ #:use-module (gnu packages benchmark)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
@@ -1108,7 +1109,7 @@ well as bzip2.")
(define-public snappy
(package
(name "snappy")
- (version "1.1.8")
+ (version "1.1.9")
(source
(origin
(method git-fetch)
@@ -1117,11 +1118,35 @@ well as bzip2.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1j0kslq2dvxgkcxl1gakhvsa731yrcvcaipcp5k8k7ayicvkv9jv"))
- (patches (search-patches "snappy-add-O2-flag-in-CmakeLists.txt.patch"))))
+ (base32 "03zz56h79z0sgvi5sangjqn9dahhzvf645v26n1y0gwmfbmsax95"))
+ (patches
+ (search-patches "snappy-add-O2-flag-in-CmakeLists.txt.patch"
+ "snappy-add-inline-for-GCC.patch"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+ `(#:configure-flags
+ (list "-DBUILD_SHARED_LIBS=ON"
+ ;; These would be installed alongside Snappy otherwise.
+ "-DBENCHMARK_ENABLE_INSTALL=OFF"
+ "-DINSTALL_GTEST=OFF")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-third_party-subprojects
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "third_party"
+ (for-each (lambda (subproject)
+ (let* ((input (string-append subproject "-source"))
+ (source (assoc-ref inputs input)))
+ (with-directory-excursion subproject
+ ;; Take advantage of the coincidence that both
+ ;; use GIT-FETCH, which creates a directory.
+ (copy-recursively source "."))))
+ (list "benchmark"
+ "googletest"))
+ #;punt))))))
+ (native-inputs
+ `(("benchmark-source" ,(package-source benchmark))
+ ("googletest-source" ,(package-source googletest))))
(home-page "https://github.com/google/snappy")
(synopsis "Fast compressor/decompressor")
(description "Snappy is a compression/decompression library. It does not