summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-05 22:56:40 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-06 00:18:30 +0000
commita8448da0f4a090818104e64dd79f90b0e50d5e77 (patch)
tree494c58b4724f12cd9de0db9b0a7096de2b922c0f /gnu/packages/compression.scm
parent4f4b749e75b38b8c08b4f67ef51c2c8740999e28 (diff)
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar
guix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 972b227dab..f96ed1fd6f 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Léo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
+;;; Copyright © 2021 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -890,14 +891,14 @@ extract such file systems.")
(define-public pigz
(package
(name "pigz")
- (version "2.4")
+ (version "2.6")
(source (origin
(method url-fetch)
(uri (string-append "http://zlib.net/pigz/"
name "-" version ".tar.gz"))
(sha256
(base32
- "0wsgw5vwl23jrnpsvd8v3xcp5k4waw5mk0164fynjhkv58i1dy54"))))
+ "0z9avc4mifwcpj3qdsf9m2rjw9jx03b2r9pj0c4xgla9fh6ppv9f"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1037,7 +1038,7 @@ smaller than those produced by @code{Xdelta}.")
(define-public libjcat
(package
(name "libjcat")
- (version "0.1.5")
+ (version "0.1.6")
(source
(origin
(method git-fetch)
@@ -1047,7 +1048,7 @@ smaller than those produced by @code{Xdelta}.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0rxyqikdhkh2nq1y0hy05df2kkxf3d2cp6lm5x1s5i717k6y3zy5"))))
+ (base32 "1a2z34m8611xvna9kwch8ralxx7c9mk4rm9vrxx7p9hr8sbqbsaz"))))
(build-system meson-build-system)
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -1109,16 +1110,15 @@ human-readable output.")
(define-public lrzip
(package
(name "lrzip")
- (version "0.631")
+ (version "0.640")
(source
(origin
(method url-fetch)
(uri (string-append
- "http://ck.kolivas.org/apps/lrzip/lrzip-" version ".tar.bz2"))
+ "http://ck.kolivas.org/apps/lrzip/lrzip-" version ".tar.xz"))
(sha256
(base32
- "0mb449vmmwpkalq732jdyginvql57nxyd31sszb108yps1lf448d"))
- (patches (search-patches "lrzip-CVE-2017-8842.patch"))))
+ "175466drfpz8rsfr0pzfn5rqrj3wmcmcs3i2sfmw366w2kbjm4j9"))))
(build-system gnu-build-system)
(native-inputs
`(;; nasm is only required when building for 32-bit x86 platforms
@@ -1129,6 +1129,7 @@ human-readable output.")
("perl" ,perl)))
(inputs
`(("bzip2" ,bzip2)
+ ("lz4" ,lz4)
("lzo" ,lzo)
("zlib" ,zlib)))
(home-page "http://ck.kolivas.org/apps/lrzip/")
@@ -1798,14 +1799,14 @@ of archives.")
(define-public lunzip
(package
(name "lunzip")
- (version "1.11")
+ (version "1.12")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://savannah/lzip/lunzip/"
"lunzip-" version ".tar.gz"))
(sha256
- (base32 "19zq3gmlbia2krq4k4zs1j0xjdv7nsdzqvfb0pyca5n53h2mzb91"))))
+ (base32 "1liaynyy3qcs29hfk1pnb7i9r1mnmpw557j5v356qsv6qnm4lnz5"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -1825,14 +1826,14 @@ Lunzip is intended to be fully compatible with the regular lzip package.")
(define-public clzip
(package
(name "clzip")
- (version "1.11")
+ (version "1.12")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://savannah/lzip/clzip/"
"clzip-" version ".tar.gz"))
(sha256
- (base32 "1h14dmc9fi10gcdpdpbgq1bwvcxvivppilj64pf720x8mw915mfr"))))
+ (base32 "1s7yidqvmxi61hh569h5aci816l6qkffjgx0zx57qyyq0qq2pjgw"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -2237,7 +2238,7 @@ file compression algorithm.")
(define-public xarchiver
(package
(name "xarchiver")
- (version "0.5.4.16")
+ (version "0.5.4.17")
(source
(origin
(method git-fetch)
@@ -2246,7 +2247,7 @@ file compression algorithm.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0nblyk65w1in0zpfbyzy6dw4x0fzx3q7xs85dby5ap4w0gjz9s44"))))
+ (base32 "00adrjpxqlaccrwjf65w3vhxfswdj0as8aj263c6f9b85llypc5v"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)