summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-20 17:19:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-20 17:19:00 +0100
commit901236474a9523595c0bdefd5ac22366e78b9e61 (patch)
tree667efe648d584b0c960b0da0d577b8a71b6b941c /gnu/packages/compression.scm
parent63d4ef52ebad4157817d56ccbe974da8fff81929 (diff)
parent64766d5cafd5cf19189ed274eb7e29ef784f90de (diff)
downloadguix-patches-901236474a9523595c0bdefd5ac22366e78b9e61.tar
guix-patches-901236474a9523595c0bdefd5ac22366e78b9e61.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm77
1 files changed, 46 insertions, 31 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 6314546667..f619f62699 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
-;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018 Marius Bakke <mbakke@fastmail.com>
@@ -557,14 +557,14 @@ archiving. Lzip is a clean implementation of the LZMA algorithm.")
(define-public lziprecover
(package
(name "lziprecover")
- (version "1.20")
+ (version "1.21")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://savannah/lzip/" name "/"
- name "-" version ".tar.gz"))
+ (uri (string-append "mirror://savannah/lzip/lziprecover/"
+ "lziprecover-" version ".tar.gz"))
(sha256
(base32
- "0fpnmdxayvd1ff0rk9606dvr431ji6b1v71km4ww244rih1rmmzz"))))
+ "094w2z8fz41yaq0gkyr61cl7pb1d7kchpl5dka7rvm3qvbb7ncd2"))))
(build-system gnu-build-system)
(home-page "https://www.nongnu.org/lzip/lziprecover.html")
(synopsis "Recover and decompress data from damaged lzip files")
@@ -1278,7 +1278,7 @@ or junctions, and always follows hard links.")
(define-public unshield
(package
(name "unshield")
- (version "1.4.2")
+ (version "1.4.3")
(source
(origin (method url-fetch)
(uri (string-append "http://github.com/twogood/unshield/archive/"
@@ -1286,25 +1286,36 @@ or junctions, and always follows hard links.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0x7ps644yp5dka2zhb8w0ifqmw3d255jafpzfwv8xbcpgq6fmm2x"))))
+ "1avv5c11jbmzwizq10pwvlh1dmyna8ccvpgacv95h4gbq26rg35a"))))
(build-system cmake-build-system)
(inputs
`(("zlib" ,zlib)
("openssl" ,openssl)
- ;; test data that is otherwise downloaded with curl
+ ;; Test data that is otherwise downloaded with curl.
("unshield-avigomanager11b22.zip"
,(origin
(method url-fetch)
- (uri (string-append "https://www.dropbox.com/s/8r4b6752swe3nhu/"
- "unshield-avigomanager11b22.zip?dl=1"))
+ (uri (string-append
+ "https://www.dropbox.com/s/8r4b6752swe3nhu/"
+ "unshield-avigomanager11b22.zip?dl=1"))
(sha256
(base32 "0fwq7lih04if68wpwpsk5wjqyvh32db76a41sq6gbx4dn1lc3ddn"))
(file-name "unshield-avigomanager11b22.zip")))
+ ("unshield-baldurs_gate_patch_v1_1_4315_international.zip"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.dropbox.com/s/9ruil8oi6amjbbk/"
+ "unshield-baldurs_gate_patch_v1_1_4315_international.zip?dl=1"))
+ (sha256
+ (base32 "0spaxf6dardlhqxz3ys09fzamj007q3nfyw4xng6gh3qp9780maj"))
+ (file-name "unshield-baldurs_gate_patch_v1_1_4315_international.zip")))
("unshield-the-feeble-files-spanish.zip"
,(origin
(method url-fetch)
- (uri (string-append "https://www.dropbox.com/s/1ng0z9kfxc7eb1e/"
- "unshield-the-feeble-files-spanish.zip?dl=1"))
+ (uri (string-append
+ "https://www.dropbox.com/s/1ng0z9kfxc7eb1e/"
+ "unshield-the-feeble-files-spanish.zip?dl=1"))
(sha256
(base32 "1k5cw6vnpja8yjlnhx5124xrw9i8s1l539hfdqqrqz3l5gn0bnyd"))
(file-name "unshield-the-feeble-files-spanish.zip")))))
@@ -1320,6 +1331,7 @@ or junctions, and always follows hard links.")
(copy-file (assoc-ref inputs i)
(string-append "test/v0/" i)))
'("unshield-avigomanager11b22.zip"
+ "unshield-baldurs_gate_patch_v1_1_4315_international.zip"
"unshield-the-feeble-files-spanish.zip"))
(substitute* (find-files "test/" "/*\\.sh")
;; Tests expect the unshield binary in a specific
@@ -1332,7 +1344,12 @@ or junctions, and always follows hard links.")
(substitute* "test/v0/avigomanager.sh"
(("test.zip")
(string-append (getcwd)
- "/test/v0/unshield-avigomanager11b22.zip")))
+ "/test/v0/unshield-avigomanager11b22.zip")))
+ (substitute* "test/v0/baldurs_gate_patch_v1_1_4315_international.sh"
+ (("test.zip")
+ (string-append
+ (getcwd)
+ "/test/v0/unshield-baldurs_gate_patch_v1_1_4315_international.zip")))
(substitute* "test/v0/the-feeble-files-spanish.sh"
(("test.zip")
(string-append (getcwd)
@@ -1623,14 +1640,14 @@ of archives.")
(define-public lunzip
(package
(name "lunzip")
- (version "1.10")
+ (version "1.11")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://savannah/lzip/"
- name "/" name "-" version ".tar.gz"))
+ (uri (string-append "mirror://savannah/lzip/lunzip/"
+ "lunzip-" version ".tar.gz"))
(sha256
- (base32 "1iw59br6nsxs7l1p875h8w3vxwr04xfhg5zyal64crvamhxkj5kl"))))
+ (base32 "19zq3gmlbia2krq4k4zs1j0xjdv7nsdzqvfb0pyca5n53h2mzb91"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -1650,14 +1667,14 @@ Lunzip is intended to be fully compatible with the regular lzip package.")
(define-public clzip
(package
(name "clzip")
- (version "1.10")
+ (version "1.11")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://savannah/lzip/"
- name "/" name "-" version ".tar.gz"))
+ (uri (string-append "mirror://savannah/lzip/clzip/"
+ "clzip-" version ".tar.gz"))
(sha256
- (base32 "03xcmhl3dya4jrwmsqh09ikimpb36fr3vkh2bwfzz1sbcns0cdg3"))))
+ (base32 "1h14dmc9fi10gcdpdpbgq1bwvcxvivppilj64pf720x8mw915mfr"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -1676,17 +1693,15 @@ Clzip is intended to be fully compatible with the regular lzip package.")
(define-public lzlib
(package
(name "lzlib")
- (version "1.10")
+ (version "1.11")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://savannah/lzip/"
- name "/" name "-" version ".tar.gz"))
+ (uri (string-append "mirror://savannah/lzip/lzlib/"
+ "lzlib-" version ".tar.gz"))
(sha256
- (base32 "0hqhnj2lzqacdbmmnpy91lsm1rd9zlngs1q6s9pyahsv1a0bfshx"))))
+ (base32 "0djdj4sg33rzi4k84cygvnp09bfsv6i8wy2k7i67rayib63myp3c"))))
(build-system gnu-build-system)
- ;; The included minilzip binary is only ~16 smaller than the ‘real’ lzip.
- ;; It's used during the test suite, but don't be tempted to install it.
(arguments
`(#:configure-flags
(list "CC=gcc"
@@ -1704,14 +1719,14 @@ corrupted input.")
(define-public plzip
(package
(name "plzip")
- (version "1.7")
+ (version "1.8")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://savannah/lzip/"
- name "/" name "-" version ".tar.gz"))
+ (uri (string-append "mirror://savannah/lzip/plzip/"
+ "plzip-" version ".tar.gz"))
(sha256
- (base32 "1dzjp9r7krwpsn224bhcqbzd5aj5b4556sdi9yzl2bzbk3fjrqlm"))))
+ (base32 "04indil809qgfmz776imb3dnhkysh7zk28jcv3mw0ahl2lyaxbzd"))))
(build-system gnu-build-system)
(inputs
`(("lzlib" ,lzlib)))