summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-08-22 15:53:27 -0400
committerMark H Weaver <mhw@netris.org>2019-08-22 15:53:27 -0400
commit893c2df00daa4e6dd6a7ff3813d7df5329877f9e (patch)
treeacd0db459464acae47083b66d5ce12cc656e2f10 /gnu/packages/compression.scm
parent04b9b7bb05aff4c41f46cd79aa7bc953ace16e86 (diff)
parent0ccc9a0f5bb89b239d56157ea66f8420fcec5ba6 (diff)
downloadguix-patches-893c2df00daa4e6dd6a7ff3813d7df5329877f9e.tar
guix-patches-893c2df00daa4e6dd6a7ff3813d7df5329877f9e.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 774abad5c9..64d995b8fd 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -2002,3 +2002,49 @@ reading from and writing to ZIP archives. ")
;; Project is distributed under LGPL, but "quazip/z*" "quazip/unzip.*" are
;; distributed under zlib terms.
(license (list license:lgpl2.1+ license:zlib))))
+
+(define-public zutils
+ (package
+ (name "zutils")
+ ;; Check and remove the lint-hidden-cve property when updating.
+ (version "1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/zutils/zutils-" version ".tar.lz"))
+ (sha256
+ (base32 "0dx35mv78fgqgz6sszs05ng8ipz2xy09ry9vpmka2rmy08b7x907"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--sysconfdir=/etc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (apply invoke "make" "install"
+ (string-append "sysconfdir=" (assoc-ref outputs "out")
+ "/etc")
+ make-flags))))))
+ (native-inputs
+ ;; Needed to extract the source tarball and run the test suite.
+ `(("lzip" ,lzip)))
+ (properties `((lint-hidden-cve . ("CVE-2018-1000637"))))
+ (home-page "https://www.nongnu.org/zutils/zutils.html")
+ (synopsis "Utilities that transparently operate on compressed files")
+ (description
+ "Zutils is a collection of utilities able to process any combination of
+compressed and uncompressed files transparently. If any given file, including
+standard input, is compressed, its decompressed content is used instead.
+
+@command{zcat}, @command{zcmp}, @command{zdiff}, and @command{zgrep} are
+improved replacements for the shell scripts provided by GNU gzip.
+@command{ztest} tests the integrity of supported compressed files.
+@command{zupdate} recompresses files with lzip, similar to gzip's
+@command{znew}.
+
+Supported compression formats are bzip2, gzip, lzip, and xz. Zutils uses
+external compressors: the compressor to be used for each format is configurable
+at run time, and must be installed separately.")
+ (license (list license:bsd-2 ; arg_parser.{cc,h}
+ license:gpl2+)))) ; the rest