summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-02 11:47:17 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-02 11:47:17 +0200
commitfb40ec8aab105706a14b0b2299f38a8fd3e62377 (patch)
treef63b16ab5be2c010f1374930e3243575a89d816b /gnu/packages/commencement.scm
parent98c075c24e26798ef52ab66641faa7b0aa87726b (diff)
downloadguix-patches-fb40ec8aab105706a14b0b2299f38a8fd3e62377.tar
guix-patches-fb40ec8aab105706a14b0b2299f38a8fd3e62377.tar.gz
gnu: findutils-boot0: Really disable 'test-fnmatch' on i686-linux.
Commit f08b070019a3c1697bb0b4a783dcd4f31243715a intended to skip 'test-fnmatch' on both x86_64-linux and i686-linux but it ended up skipping it on x86_64-linux only. * gnu/packages/commencement.scm (findutils-boot0)[arguments]: Use 'member' to test whether (%current-system) is "x86_64-linux" or "i686-linux".
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 1ae37d7105..9e8bbf97be 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2516,14 +2516,14 @@ exec " gcc "/bin/" program
;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
;; to incorrect handling of the [:alpha:] regexp character
;; class. Ignore it.
- ,@(if (string=? (%current-system)
- (or "x86_64-linux" "i686-linux"))
- '((add-before 'check 'skip-fnmatch-test
- (lambda _
- (substitute* "gnulib-tests/Makefile"
- (("^XFAIL_TESTS =")
- "XFAIL_TESTS = test-fnmatch ")))))
- '()))))))))
+ ,@(if (member (%current-system)
+ '("x86_64-linux" "i686-linux"))
+ '((add-before 'check 'skip-fnmatch-test
+ (lambda _
+ (substitute* "gnulib-tests/Makefile"
+ (("^XFAIL_TESTS =")
+ "XFAIL_TESTS = test-fnmatch ")))))
+ '()))))))))
(define file
(package