summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-13 23:36:39 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-14 00:08:10 +0200
commitefa8fddabedbfcec85f19a6d8b431f0adabfe537 (patch)
tree0063b07e9d983960b37e16b10810b5e691f42cc7 /gnu/packages/commencement.scm
parent8f417ed28061c11c7ff2649cfa15e35b00ef9a0b (diff)
downloadguix-patches-efa8fddabedbfcec85f19a6d8b431f0adabfe537.tar
guix-patches-efa8fddabedbfcec85f19a6d8b431f0adabfe537.tar.gz
gnu: commencement: Use 'package-with-explicit-inputs' for Hurd packages.
* gnu/packages/commencement.scm (with-boot0): New procedure. (gnumach-headers-boot0, mig-boot0) (hurd-headers-boot0, hurd-minimal-boot0) (hurd-core-headers-boot0): Use it instead of 'package-with-explicit-inputs'.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm45
1 files changed, 18 insertions, 27 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index fd976e0c2f..54746151ce 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1798,15 +1798,16 @@ exec " gcc "/bin/" program
("bison" ,bison-boot0)
,@(%boot0-inputs))))))
+(define with-boot0
+ (package-with-explicit-inputs %boot0-inputs
+ %bootstrap-guile))
+
(define gnumach-headers-boot0
- (package-with-bootstrap-guile
- (package-with-explicit-inputs gnumach-headers
- (%boot0-inputs)
- (current-source-location)
- #:guile %bootstrap-guile)))
+ (with-boot0 (package-with-bootstrap-guile gnumach-headers)))
(define mig-boot0
- (let* ((mig (package (inherit mig)
+ (let* ((mig (package
+ (inherit (package-with-bootstrap-guile mig))
(native-inputs `(("bison" ,bison-boot0)
("flex" ,flex-boot0)))
(inputs `(("flex" ,flex-boot0)))
@@ -1814,42 +1815,32 @@ exec " gcc "/bin/" program
`(#:configure-flags
`(,(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %build-inputs "flex") "/lib/")))))))
- (package-with-bootstrap-guile
- (package-with-explicit-inputs mig (%boot0-inputs)
- (current-source-location)
- #:guile %bootstrap-guile))))
+ (with-boot0 mig)))
(define hurd-headers-boot0
(let ((hurd-headers (package (inherit hurd-headers)
(native-inputs `(("mig" ,mig-boot0)))
(inputs '()))))
- (package-with-bootstrap-guile
- (package-with-explicit-inputs hurd-headers (%boot0-inputs)
- (current-source-location)
- #:guile %bootstrap-guile))))
+ (with-boot0 (package-with-bootstrap-guile hurd-headers))))
(define hurd-minimal-boot0
(let ((hurd-minimal (package (inherit hurd-minimal)
(native-inputs `(("mig" ,mig-boot0)))
(inputs '()))))
- (package-with-bootstrap-guile
- (package-with-explicit-inputs hurd-minimal (%boot0-inputs)
- (current-source-location)
- #:guile %bootstrap-guile))))
+ (with-boot0 (package-with-bootstrap-guile hurd-minimal))))
(define hurd-core-headers-boot0
(mlambda ()
"Return the Hurd and Mach headers as well as initial Hurd libraries for
the bootstrap environment."
- (package-with-bootstrap-guile
- (package (inherit hurd-core-headers)
- (arguments `(#:guile ,%bootstrap-guile
- ,@(package-arguments hurd-core-headers)))
- (inputs
- `(("gnumach-headers" ,gnumach-headers-boot0)
- ("hurd-headers" ,hurd-headers-boot0)
- ("hurd-minimal" ,hurd-minimal-boot0)
- ,@(%boot0-inputs)))))))
+ (package (inherit (package-with-bootstrap-guile hurd-core-headers))
+ (arguments `(#:guile ,%bootstrap-guile
+ ,@(package-arguments hurd-core-headers)))
+ (inputs
+ `(("gnumach-headers" ,gnumach-headers-boot0)
+ ("hurd-headers" ,hurd-headers-boot0)
+ ("hurd-minimal" ,hurd-minimal-boot0)
+ ,@(%boot0-inputs))))))
(define* (kernel-headers-boot0 #:optional (system (%current-system)))
(match system