summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-03 17:16:08 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2018-11-24 08:18:32 +0100
commit77e02d948c9e16ae894ea0eba2c1e706d03d09e1 (patch)
treea92ef34a7bfca38ac40d58d83b2ca324132e4c76 /gnu/packages/commencement.scm
parenta6facf94828b7215566c724822f00feee36f60a9 (diff)
downloadguix-patches-77e02d948c9e16ae894ea0eba2c1e706d03d09e1.tar
guix-patches-77e02d948c9e16ae894ea0eba2c1e706d03d09e1.tar.gz
gnu: gcc-boot0: Improve gcc-wrapper workarounds.
* gnu/packages/commencement.scm (gcc-boot0)[arguments]: Adjust the libcc1 build scripts instead of copying libcc1.so from %BOOT0-INPUTS.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 467a1585ff..f9770425a8 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1731,13 +1731,18 @@ exec " gcc "/bin/" program
#t)))
,(match (%current-system)
((or "i686-linux" "x86_64-linux")
- '(add-after 'build 'libtool-workaround
- (lambda _
- ;; libtool: install: /gnu/store/7swwdnq02lqk4xkd8740fxdj1h4va38l-bootstrap-binaries-0/bin/install -c .libs/libcc1.so.0.0.0 /gnu/store/8qf47i99nxz9jvrmq5va0g3q1yvs3x74-gcc-cross-boot0-5.5.0-lib/lib/./libcc1.so.0.0.0
- ;; /gnu/store/7swwdnq02lqk4xkd8740fxdj1h4va38l-bootstrap-binaries-0/bin/install: cannot stat '.libs/libcc1.so.0.0.0': No such file or directory
- (system* "touch"
- "libcc1/.libs/libcc1.so.0.0.0"
- "libcc1/.libs/libcc1plugin.so.0.0.0"))))
+ '(add-before 'configure 'fix-libcc1
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; libcc1.so NEEDs libgcc_s.so, so provide one here
+ ;; to placate the 'validate-runpath' phase.
+ (substitute* "libcc1/Makefile.in"
+ (("la_LDFLAGS =")
+ (string-append "la_LDFLAGS = -Wl,-rpath="
+ (assoc-ref inputs "gcc") "/lib")))
+ ;; XXX: "g++ -v" is broken (see also libstdc++ above).
+ (substitute* "libcc1/configure"
+ (("g\\+\\+ -v") "true"))
+ #t)))
(_ identity))
(add-after 'install 'symlink-libgcc_eh
(lambda* (#:key outputs #:allow-other-keys)