summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-08 20:22:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-08 20:22:42 +0100
commit5e268faf85c60b5e12cbc742c5e3bf3d20771cb9 (patch)
tree323e3371549a30f5ab39140baeddd57104a62c80 /gnu/packages/commencement.scm
parent236b7aed8267c1493b6ab76482a774643c1e11d5 (diff)
downloadguix-patches-5e268faf85c60b5e12cbc742c5e3bf3d20771cb9.tar
guix-patches-5e268faf85c60b5e12cbc742c5e3bf3d20771cb9.tar.gz
gnu: Remove gcc-for-libstdc++.
* gnu/packages/commencement.scm (libstdc++-boot0): Remove variable. (libstdc++-boot0): Use GCC-4.9 instead.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm18
1 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 3636b54b0b..a475016876 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -177,28 +177,12 @@
,cf)))))
(inputs %boot0-inputs))))
-;; gcc-4.9 was fixed late in the core-update cycle and so this GCC is only
-;; needed to prevent a full world rebuild, and can be replaced with gcc-4.9.
-(define gcc-for-libstdc++
- (package (inherit gcc-4.9)
- (version "4.9.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/gcc/gcc-"
- version "/gcc-" version ".tar.bz2"))
- (sha256
- (base32
- "14l06m7nvcvb0igkbip58x59w3nq6315k6jcz3wr9ch1rn9d44bc"))
- (patches (search-patches "gcc-arm-bug-71399.patch"
- "gcc-libvtv-runpath.patch"
- "gcc-fix-texi2pod.patch"))))))
-
(define libstdc++-boot0
;; GCC's libcc1 is always built as a shared library (the top-level
;; 'Makefile.def' forcefully adds --enable-shared) and thus needs to refer
;; to libstdc++.so. We cannot build libstdc++-5.3 because it relies on
;; C++14 features missing in some of our bootstrap compilers.
- (let ((lib (package-with-bootstrap-guile (make-libstdc++ gcc-for-libstdc++))))
+ (let ((lib (package-with-bootstrap-guile (make-libstdc++ gcc-4.9))))
(package
(inherit lib)
(name "libstdc++-boot0")