summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-07-04 17:39:54 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-04 18:05:59 +0200
commit58a75996ecdd09431f943c4d55b199b8aceea72d (patch)
treeaac851fefb2134e2d2fce23ee94dbf8f9eca4666 /gnu/packages/commencement.scm
parente94b95473ea5dadea76be9763b7f8b34d400e863 (diff)
downloadguix-patches-58a75996ecdd09431f943c4d55b199b8aceea72d.tar
guix-patches-58a75996ecdd09431f943c4d55b199b8aceea72d.tar.gz
gnu: glibc-utf8-locales: Fix cross-compilation.
* gnu/packages/base.scm (glibc-utf8-locales)[inputs]: Move to ... [native-inputs]: ... here, in order to fix cross-compilation. * gnu/packages/commencement.scm (glibc-utf8-locales-final)[inputs]: Move to ... [native-inputs]: ... here, in order to fix cross-compilation.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 4a41e2abf3..f00cfa7bd8 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -882,11 +882,12 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
;; function.)
(package
(inherit glibc-utf8-locales)
- (inputs `(("glibc" ,glibc-final)
- ("gzip"
- ,(package-with-explicit-inputs gzip %boot4-inputs
- (current-source-location)
- #:guile %bootstrap-guile))))))
+ (native-inputs
+ `(("glibc" ,glibc-final)
+ ("gzip"
+ ,(package-with-explicit-inputs gzip %boot4-inputs
+ (current-source-location)
+ #:guile %bootstrap-guile))))))
(define-public ld-wrapper
;; The final 'ld' wrapper, which uses the final Guile and Binutils.